p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de ruby-thrift

Vulnerabilidades publicadas para ruby-thrift en los últimos 30 días: 3. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 4

  1. CVE-2026-96277

    Alta · CVSS 8.7EPSS 0,34%Sin corrección publicada

    Apache Thrift: Ruby `SimpleServer` ends `serve()` on any non-Transport/Protocol exception

    Uncaught exception, Improper Handling of Exceptional Conditions vulnerability in Apache Thrift Ruby bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.

    Publicación Actualización
  2. CVE-2026-94656

    Alta · CVSS 8.2EPSS 0,34%Sin corrección publicada

    Apache Thrift: rb `TJsonProtocol`/`TJSONProtocol` has no string size bound

    Allocation of resources without limits or throttling vulnerability in Apache Thrift ruby bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.

    Publicación Actualización
  3. CVE-2026-85494

    Alta · CVSS 8.7EPSS 0,31%Sin corrección publicada

    Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift: Framed transport and binary protocol size read buffers from a peer-declared length without a limit (multi-language)

    Improper handling of length parameter inconsistency, Uncaught exception, Inefficient Algorithmic Complexity, Memory allocation with excessive size value, Initialization of a resource with an insecure default vulnerability in Apache Thrift Python, Ruby, Erlang, Lua, Dart, JavaME, Perl, PHP and D language bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.

    Publicación Actualización
  4. CVE-2026-49158

    Alta · CVSS 7.5EPSS 1,03%Sin corrección publicada

    Apache Thrift: Ruby THeaderTransport ZLIB Decompression Bomb

    Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Ruby bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →