p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de cups · Página 2

Vulnerabilidades publicadas para cups en los últimos 30 días: 9. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 27

  1. CVE-2025-58436

    Media · CVSS 5.1EPSS 0,23%Corrección disponible

    OpenPrinting CUPS slow client can halt cupsd, leading to a possible DoS attack

    OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to version 2.4.15, a client that connects to cupsd but sends slow messages, e.g. only one byte per second, delays cupsd as a whole, such that it becomes unusable by other clients. This issue has been patched in version 2.4.15.

    • Actualiza a 2.4.7-1.2ubuntu7.9
    Publicación Actualización
  2. CVE-2025-61915

    Media · CVSS 6EPSS 0,46%Corrección disponible

    OpenPrinting CUPS vulnerable to stack based out-of-bound write

    OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to version 2.4.15, a user in the lpadmin group can use the cups web ui to change the config and insert a malicious line. Then the cupsd process which runs as root will parse the new config and cause an out-of-bound write. This issue has been patched in version 2.4.15.

    • Actualiza a 2.4.7-1.2ubuntu7.7
    Publicación Actualización
  3. CVE-2025-58364

    Media · CVSS 6.5EPSS 1,16%Corrección disponible

    cups: Remote DoS via null dereference

    OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. In versions 2.4.12 and earlier, an unsafe deserialization and validation of printer attributes causes null dereference in the libcups library. This is a remote DoS vulnerability available in local subnet in default configurations. It can cause the cups & cups-browsed to crash, on all the machines in local network who are listening for printers (so by default for all regular linux machines). On systems where the vulnerability CVE-2024-47176 (cups-filters 1.x/cups-browsed 2.x vulnerability) was not fixed, and the firewall on the machine does not

    • Actualiza a 2.4.7-1.2ubuntu7.4
    Publicación Actualización
  4. CVE-2025-58060

    Alta · CVSS 8EPSS 1%Corrección disponible

    cups has Authentication bypass with AuthType Negotiate

    OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. In versions 2.4.12 and earlier, when the `AuthType` is set to anything but `Basic`, if the request contains an `Authorization: Basic ...` header, the password is not checked. This results in authentication bypass. Any configuration that allows an `AuthType` that is not `Basic` is affected. Version 2.4.13 fixes the issue.

    • Actualiza a 2.4.7-1.2ubuntu7.4
    Publicación Actualización
  5. CVE-2024-47175

    Alta · CVSS 8.6EPSS 63,61%Código de explotación públicoCorrección disponible

    libppd's ppdCreatePPDFromIPP2 function does not sanitize IPP attributes when creating the PPD buffer

    CUPS is a standards-based, open-source printing system, and `libppd` can be used for legacy PPD file support. The `libppd` function `ppdCreatePPDFromIPP2` does not sanitize IPP attributes when creating the PPD buffer. When used in combination with other functions such as `cfGetPrinterAttributes5`, can result in user controlled input and ultimately code execution via Foomatic. This vulnerability can be part of an exploit chain leading to remote code execution (RCE), as described in CVE-2024-47176.

    • Actualiza a 2.4.7-1.2ubuntu7.3
    Publicación Actualización
  6. USN-6844-2

    Sin evaluarCorrección disponible

    cups regression

    USN-6844-1 fixed vulnerabilities in the CUPS package. The update lead to the discovery of a regression in CUPS with regards to how the cupsd daemon handles Listen configuration directive. This update fixes the problem. We apologize for the inconvenience. Original advisory details: Rory McNamara discovered that when starting the cupsd server with a Listen configuration item, the cupsd process fails to validate if bind call passed. An attacker could possibly trick cupsd to perform an arbitrary chmod of the provided argument, providing world-writable access to the target.

    • Actualiza a 2.4.7-1.2ubuntu7.2
    Publicación Actualización
  7. CVE-2024-35235

    Media · CVSS 4.4EPSS 2,42%Corrección disponible

    Cupsd Listen arbitrary chmod 0140777

    OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. In versions 2.4.8 and earlier, when starting the cupsd server with a Listen configuration item pointing to a symbolic link, the cupsd process can be caused to perform an arbitrary chmod of the provided argument, providing world-writable access to the target. Given that cupsd is often running as root, this can result in the change of permission of any user or system files to be world writable. Given the aforementioned Ubuntu AppArmor context, on such systems this vulnerability is limited to those files modifiable by the cupsd process. In that s

    • Actualiza a 2.4.7-1.2ubuntu7.1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →