p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de xz-utils

Vulnerabilidad publicada para xz-utils en los últimos 30 días: 1. En el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 3

  1. USN-8945-1

    Sin evaluarCorrección disponible

    xz-utils vulnerability

    It was discovered that XZ Utils incorrectly handled certain memory allocation failures when reinitializing decoders for specific compressed file formats. An attacker could possibly use this issue to trigger an invalid memory write, resulting in a denial of service or arbitrary code execution.

    • Actualiza a 5.6.1+really5.4.5-1ubuntu0.4
    Publicación Actualización
  2. CVE-2026-34743

    Baja · CVSS 1.7EPSS 0,51%Corrección disponible

    XZ Utils: Buffer overflow in lzma_index_append()

    XZ Utils provide a general-purpose data-compression library plus command-line tools. Prior to version 5.8.3, if lzma_index_decoder() was used to decode an Index that contained no Records, the resulting lzma_index was left in a state where where a subsequent lzma_index_append() would allocate too little memory, and a buffer overflow would occur. This issue has been patched in version 5.8.3.

    • Actualiza a 5.6.1+really5.4.5-1ubuntu0.3
    Publicación Actualización
  3. CVE-2025-31115

    Alta · CVSS 8.7EPSS 0,68%Corrección disponible

    XZ has a heap-use-after-free bug in threaded .xz decoder

    XZ Utils provide a general-purpose data-compression library plus command-line tools. In XZ Utils 5.3.3alpha to 5.8.0, the multithreaded .xz decoder in liblzma has a bug where invalid input can at least result in a crash. The effects include heap use after free and writing to an address based on the null pointer plus an offset. Applications and libraries that use the lzma_stream_decoder_mt function are affected. The bug has been fixed in XZ Utils 5.8.1, and the fix has been committed to the v5.4, v5.6, v5.8, and master branches in the xz Git repository. No new release packages will be made from the old stable branches, but a standalone patch i

    • Actualiza a 5.6.1+really5.4.5-1ubuntu0.2
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →