p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de dnsmasq

Vulnerabilidades publicadas para dnsmasq en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 18

  1. CVE-2026-13002

    Media · CVSS 4.4EPSS 0,15%Sin corrección publicada

    Dnsmasq: infinite loop dos in dnssec nsec/nsec3 type bitmap parsing

    A flow has been identified into dnssec.c library, causing an infinite loop to dnsmasq service. An attacker who controls any DNSSEC-signed zone can hang the dnsmasq process with a single crafted response, killing all DNS resolution for its clients.

    Publicación Actualización
  2. CVE-2026-12969

    Media · CVSS 5.3EPSS 0,26%Corrección disponible

    Dnsmasq: dnsmasq: out-of-bounds read in find_soa() due to missing extrabytes validation

    An out-of-bounds read vulnerability exists in dnsmasq's find_soa() function in src/rfc1035.c. When parsing NS section records, extract_name() is called with extrabytes=0, failing to validate that 10 additional bytes exist for fixed-length DNS record fields. A remote attacker controlling a DNS zone can exploit this via a crafted NXDOMAIN response to cause a 10-byte heap out-of-bounds read, potentially accessing stale data from prior transactions.

    • Actualiza a 2.90-0ubuntu0.16.04.1+esm4
    Publicación Actualización
  3. CVE-2026-12725

    Media · CVSS 5.9EPSS 0,53%Corrección disponible

    Dnsmasq: dnsmasq: heap buffer overflow in log_query() when logging unsupported ds/dnskey replies

    A heap-based buffer overflow was found in dnsmasq. When DNSSEC validation and query logging are both enabled, logging of DS or DNSKEY replies containing unsupported algorithm or digest types can cause dnsmasq to write past the end of an internal logging buffer. A remote attacker able to supply such a DNS response may crash the dnsmasq process, resulting in denial of service.

    • Actualiza a 2.90-0ubuntu0.16.04.1+esm4
    Publicación Actualización
  4. CVE-2026-5172

    Alta · CVSS 7.3EPSS 2,68%Corrección disponible

    CVE-2026-5172

    A buffer overflow in dnsmasq’s extract_addresses() function allows an attacker to trigger a heap out-of-bounds read and crash by exploiting a malformed DNS response, enabling extract_name() to advance the pointer past the record’s end.

    • Actualiza a 2.90-0ubuntu0.16.04.1+esm3
    Publicación Actualización
  5. CVE-2026-2291

    Alta · CVSS 7.3EPSS 0,61%Código de explotación públicoCorrección disponible

    CVE-2026-2291

    dnsmasqs extract_name() function can be abused to cause a heap buffer overflow, allowing an attacker to inject false DNS cache entries, which could result in DNS lookups to redirect to an attacker-controlled IP address, or to cause a DoS.

    • Actualiza a 2.90-0ubuntu0.16.04.1+esm3
    Publicación Actualización
  6. CVE-2025-12200

    Media · CVSS 4.8Sin corrección publicada

    UBUNTU-CVE-2025-12200

    Rejected reason: ** REJECT ** DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: none. Reason: This candidate was withdrawn by its CNA. Further investigation showed that it was not a security issue. Notes: Based on the analysis by MITRE and review of community feedback, the reported conditions represent expected and intentional behavior within dnsmasq's documented design, rather than security vulnerabilities.

    Publicación Actualización
  7. CVE-2025-12199

    Media · CVSS 4.8Sin corrección publicada

    UBUNTU-CVE-2025-12199

    Rejected reason: ** REJECT ** DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: none. Reason: This candidate was withdrawn by its CNA. Further investigation showed that it was not a security issue. Notes: Based on the analysis by MITRE and review of community feedback, the reported conditions represent expected and intentional behavior within dnsmasq's documented design, rather than security vulnerabilities.

    Publicación Actualización
  8. CVE-2025-12198

    Alta · CVSS 8.5Sin corrección publicada

    UBUNTU-CVE-2025-12198

    Rejected reason: ** REJECT ** DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: none. Reason: This candidate was withdrawn by its CNA. Further investigation showed that it was not a security issue. Notes: Based on the analysis by MITRE and review of community feedback, the reported conditions represent expected and intentional behavior within dnsmasq's documented design, rather than security vulnerabilities.

    Publicación Actualización
  9. CVE-2023-50868

    Alta · CVSS 7.5EPSS 74,3%Corrección disponible

    CVE-2023-50868

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.

    • Actualiza a 2.90-0ubuntu0.16.04.1+esm1
    Publicación Actualización
  10. CVE-2023-50387

    Alta · CVSS 7.5EPSS 99,99%Corrección disponible

    CVE-2023-50387

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

    • Actualiza a 2.90-0ubuntu0.16.04.1+esm1
    Publicación Actualización
  11. CVE-2021-3448

    Media · CVSS 4EPSS 2,28%Corrección disponible

    CVE-2021-3448

    A flaw was found in dnsmasq in versions before 2.85. When configured to use a specific server for a given network interface, dnsmasq uses a fixed port while forwarding queries. An attacker on the network, able to find the outgoing port used by dnsmasq, only needs to guess the random transmission ID to forge a reply and get it accepted by dnsmasq. This flaw makes a DNS Cache Poisoning attack much easier. The highest threat from this vulnerability is to data integrity.

    • Actualiza a 2.79-1ubuntu0.16.04.1+esm1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →