p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de knot-resolver

Vulnerabilidades publicadas para knot-resolver en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 12

  1. CVE-2023-50868

    Alta · CVSS 7.5EPSS 74,3%Sin corrección publicada

    CVE-2023-50868

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.

    Publicación Actualización
  2. CVE-2023-50387

    Alta · CVSS 7.5EPSS 99,99%Sin corrección publicada

    CVE-2023-50387

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

    Publicación Actualización
  3. CVE-2023-26249

    Alta · CVSS 7.5EPSS 0,71%Sin corrección publicada

    CVE-2023-26249

    Knot Resolver before 5.6.0 enables attackers to consume its resources, launching amplification attacks and potentially causing a denial of service. Specifically, a single client query may lead to a hundred TCP connection attempts if a DNS server closes connections without providing a response.

    Publicación Actualización
  4. CVE-2019-19331

    Alta · CVSS 7.5EPSS 2,11%Sin corrección publicada

    CVE-2019-19331

    knot-resolver before version 4.3.0 is vulnerable to denial of service through high CPU utilization. DNS replies with very many resource records might be processed very inefficiently, in extreme cases taking even several CPU seconds for each such uncached message. For example, a few thousand A records can be squashed into one DNS message (limit is 64kB).

    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →