p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de apr-util

Vulnerabilidades publicadas para apr-util en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 5

  1. CVE-2025-49506

    Alta · CVSS 7.5EPSS 0,38%Corrección disponible

    Apache Portable Runtime Utility: apr_password_validate() vulnerable to timing attack

    APR-util versions 1.6.3 (and earlier) function apr_password_validate() was not constant-time with regards to hashes or passwords comparisons, potentially leaking their content via a side channel timing attack particularly on platforms without crypt() such as  Windows, BeOS, NetWare, or Android. Users are recommended to upgrade to version 1.6.4, which fixes this issue.

    • Actualiza a 1.6.1-2ubuntu0.1+esm1
    Publicación Actualización
  2. CVE-2026-32327

    Crítica · CVSS 9.1EPSS 0,46%Corrección disponible

    Apache Portable Runtime Utility: apr-util XML stack recursion crash

    A bug in APR-util version 1.6.3 (and earlier) allows a stack recursion attack against any library consumer which parses XML from untrusted sources and uses the apr_xml_quote_elem() function. Users are recommended to upgrade to version 1.6.4, which fixes this issue.

    • Actualiza a 1.6.1-2ubuntu0.1+esm1
    Publicación Actualización
  3. CVE-2026-34501

    Alta · CVSS 7.5EPSS 0,51%Corrección disponible

    Apache Portable Runtime Utility: Heap buffer overflow in APR redis client

    Heap-based Buffer Overflow vulnerability in Apache Portable Runtime Utility redis client. This issue affects Apache Portable Runtime Utility: from 1.6.0 through 1.6.3. Users are recommended to upgrade to version 1.6.4, which fixes the issue.

    • Actualiza a 1.6.1-2ubuntu0.1+esm1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →