p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de ghostscript

Vulnerabilidades publicadas para ghostscript en los últimos 30 días: 2. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 27

  1. CVE-2026-101258

    Alta · CVSS 7.8EPSS 0,18%Corrección disponible

    Ghostscript: ghostscript: -dsafer sandbox bypass via type 5 shading oob write and procedure-stream use-after-free

    A flaw was found in Ghostscript. When Ghostscript renders a crafted PostScript or EPS document, it can bypass the -dSAFER sandbox and execute arbitrary shell commands in the context of the Ghostscript process. The issue chains memory corruption in document parsing with disabling of internal path access controls at runtime. An attacker can deliver the document directly or through formats that delegate rendering to Ghostscript (for example EPS import or print conversion workflows). Successful exploitation can compromise confidentiality, integrity, and availability of data accessible to the process running Ghostscript.

    • Actualiza a 9.26~dfsg+0-0ubuntu0.18.04.18+esm6
    Publicación Actualización
  2. CVE-2026-103226

    Media · CVSS 5.3EPSS 0,32%Corrección disponible

    Artifex Ghostscript Pdfwrite gdevpsfx.c type1_callsubr stack-based overflow

    A vulnerability was identified in Artifex Ghostscript up to 10.07.0. Affected is the function type1_callsubr of the file devices/vector/gdevpsfx.c of the component Pdfwrite. The manipulation leads to stack-based buffer overflow. Remote exploitation of the attack is possible. The exploit is publicly available and might be used. Upgrading to version 10.08.0 is able to address this issue. It is suggested to upgrade the affected component. A solution was implemented: "I've chosen to fix this slightly differently by using the defined macro in the font parsing loop rather than in the callsubr function, because this better matches the pattern of 'no

    • Actualiza a 9.26~dfsg+0-0ubuntu0.18.04.18+esm6
    Publicación Actualización
  3. CVE-2026-39919

    Crítica · CVSS 9.3EPSS 1,15%Código de explotación públicoSin corrección publicada

    Ghostscript < 10.08.0 Heap Buffer Overflow via JPEG 2000 Output Adapter

    Ghostscript before 10.08.0 contains a heap-based buffer overflow vulnerability in the JPEG 2000 output adapter (base/sjpx_openjpeg.c) that allows attackers to cause memory corruption by supplying a crafted PDF containing a JPEG 2000 image with mismatched component subsampling factors. When image components declare different subsampling values, the non-samescale sub-byte-depth output path allocates a row buffer sized for packed output but writes a full byte per output column regardless of bit depth, overflowing the allocation and corrupting internal chunk-allocator metadata to achieve code execution.

    Publicación Actualización
  4. CVE-2026-6192

    Media · CVSS 4.8EPSS 0,11%Sin corrección publicada

    uclouvain openjpeg pi.c opj_pi_initialise_encode integer overflow

    A vulnerability was identified in uclouvain openjpeg up to 2.5.4. This impacts the function opj_pi_initialise_encode in the library src/lib/openjp2/pi.c. The manipulation leads to integer overflow. The attack must be carried out locally. The exploit is publicly available and might be used. The identifier of the patch is 839936aa33eb8899bbbd80fda02796bb65068951. It is suggested to install a patch to address this issue.

    Publicación Actualización
  5. CVE-2025-7462

    Media · CVSS 5.3EPSS 0,46%Sin corrección publicada

    Artifex GhostPDL New Output File Open Error gdevpdf.c pdf_ferror null pointer dereference

    A vulnerability was found in Artifex GhostPDL up to 3989415a5b8e99b9d1b87cc9902bde9b7cdea145. It has been classified as problematic. This affects the function pdf_ferror of the file devices/vector/gdevpdf.c of the component New Output File Open Error Handler. The manipulation leads to null pointer dereference. It is possible to initiate the attack remotely. The identifier of the patch is 619a106ba4c4abed95110f84d5efcd7aee38c7cb. It is recommended to apply a patch to fix this issue.

    Publicación Actualización
  6. CVE-2024-56827

    Media · CVSS 5.6EPSS 0,26%Corrección disponible

    Openjpeg: heap buffer overflow in lib/openjp2/j2k.c

    A flaw was found in the OpenJPEG project. A heap buffer overflow condition may be triggered when certain options are specified while using the opj_decompress utility. This can lead to an application crash or other undefined behavior.

    • Actualiza a 9.26~dfsg+0-0ubuntu0.18.04.18+esm4
    Publicación Actualización
  7. CVE-2024-56826

    Media · CVSS 5.6EPSS 0,31%Corrección disponible

    Openjpeg: heap buffer overflow in bin/common/color.c

    A flaw was found in the OpenJPEG project. A heap buffer overflow condition may be triggered when certain options are specified while using the opj_decompress utility. This can lead to an application crash or other undefined behavior.

    • Actualiza a 9.26~dfsg+0-0ubuntu0.18.04.18+esm4
    Publicación Actualización
  8. CVE-2024-46953

    Alta · CVSS 7.8EPSS 0,39%Corrección disponible

    CVE-2024-46953

    An issue was discovered in base/gsdevice.c in Artifex Ghostscript before 10.04.0. An integer overflow when parsing the filename format string (for the output filename) results in path truncation, and possible path traversal and code execution.

    • Actualiza a 9.26~dfsg+0-0ubuntu0.18.04.18+esm3
    Publicación Actualización
  9. CVE-2023-39327

    Media · CVSS 4.3EPSS 0,56%Corrección disponible

    Openjpeg: malicious files can cause the program to enter a large loop

    A flaw was found in OpenJPEG. Maliciously constructed pictures can cause the program to enter a large loop and continuously print warning messages on the terminal.

    • Actualiza a 9.26~dfsg+0-0ubuntu0.18.04.18+esm4
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →