p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de protobuf

Vulnerabilidades publicadas para protobuf en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 6

  1. CVE-2026-0994

    Alta · CVSS 8.2EPSS 0,71%Corrección disponible

    Denial of Service in Python Protobuf

    A denial-of-service (DoS) vulnerability exists in google.protobuf.json_format.ParseDict() in Python, where the max_recursion_depth limit can be bypassed when parsing nested google.protobuf.Any messages. Due to missing recursion depth accounting inside the internal Any-handling logic, an attacker can supply deeply nested Any structures that bypass the intended recursion limit, eventually exhausting Python’s recursion stack and causing a RecursionError.

    • Actualiza a 3.0.0-9.1ubuntu1.1+esm4
    Publicación Actualización
  2. CVE-2025-4565

    Alta · CVSS 8.2EPSS 0,26%Corrección disponible

    Unbounded recursion in Python Protobuf

    Any project that uses Protobuf Pure-Python backend to parse untrusted Protocol Buffers data containing an arbitrary number of recursive groups, recursive messages or a series of SGROUP tags can be corrupted by exceeding the Python recursion limit. This can result in a Denial of service by crashing the application with a RecursionError. We recommend upgrading to version =>6.31.1 or beyond commit 17838beda2943d08b8a9d4df5b68f5f04f26d901

    • Actualiza a 3.0.0-9.1ubuntu1.1+esm3
    Publicación Actualización
  3. CVE-2024-7254

    Alta · CVSS 8.7EPSS 2,77%Corrección disponible

    Stack overflow in Protocol Buffers Java Lite

    Any project that parses untrusted Protocol Buffers data containing an arbitrary number of nested groups / series of SGROUP tags can corrupted by exceeding the stack limit i.e. StackOverflow. Parsing nested groups as unknown fields with DiscardUnknownFieldsParser or Java Protobuf Lite parser, or against Protobuf map fields, creates unbounded recursions that can be abused by an attacker.

    • Actualiza a 3.0.0-9.1ubuntu1.1+esm3
    Publicación Actualización
  4. CVE-2022-3510

    Alta · CVSS 7.5EPSS 0,72%Sin corrección publicada

    Parsing issue in protobuf message-type extension

    A parsing issue similar to CVE-2022-3171, but with Message-Type Extensions in protobuf-java core and lite versions prior to 3.21.7, 3.20.3, 3.19.6 and 3.16.3 can lead to a denial of service attack. Inputs containing multiple instances of non-repeated embedded messages with repeated or unknown fields causes objects to be converted back-n-forth between mutable and immutable forms, resulting in potentially long garbage collection pauses. We recommend updating to the versions mentioned above.

    Publicación Actualización
  5. CVE-2022-3171

    Media · CVSS 4.3EPSS 1,28%Código de explotación públicoSin corrección publicada

    Memory handling vulnerability in ProtocolBuffers Java core and lite

    A parsing issue with binary data in protobuf-java core and lite versions prior to 3.21.7, 3.20.3, 3.19.6 and 3.16.3 can lead to a denial of service attack. Inputs containing multiple instances of non-repeated embedded messages with repeated or unknown fields causes objects to be converted back-n-forth between mutable and immutable forms, resulting in potentially long garbage collection pauses. We recommend updating to the versions mentioned above.

    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →