p PatchFirst

ALPINE-CVE-2022-3602

ALPINE-CVE-2022-3602

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

A buffer overrun can be triggered in X.509 certificate verification, specifically in name constraint checking. Note that this occurs after certificate chain signature verification and requires either a CA to have signed the malicious certificate or for the application to continue certificate verification despite failure to construct a path to a trusted issuer. An attacker can craft a malicious email address to overflow four attacker-controlled bytes on the stack. This buffer overflow could result in a crash (causing a denial of service) or potentially remote code execution. Many platforms implement stack overflow protections which would mitigate against the risk of remote code execution. The risk may be further mitigated based on stack layout for any given platform/compiler. Pre-announcements of CVE-2022-3602 described this issue as CRITICAL. Further analysis based on some of the mitigating factors described above have led this to be downgraded to HIGH. Users are still encouraged to upgrade to a new version as soon as possible. In a TLS client, this can be triggered by connecting to a malicious server. In a TLS server, this can be triggered if the server requests client authentication and a malicious client connects. Fixed in OpenSSL 3.0.7 (Affected 3.0.0,3.0.1,3.0.2,3.0.3,3.0.4,3.0.5,3.0.6).

CVSS 7.5 · Élevée · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · network

Produits et versions concernés

  • nodejs Alpine:v3.17

    Plages de versions concernées
    • ECOSYSTEM: < 18.12.1-r0

    Mettez à jour vers 18.12.1-r0

  • nodejs Alpine:v3.18

    Plages de versions concernées
    • ECOSYSTEM: < 18.12.1-r0

    Mettez à jour vers 18.12.1-r0

  • nodejs Alpine:v3.19

    Plages de versions concernées
    • ECOSYSTEM: < 18.12.1-r0

    Mettez à jour vers 18.12.1-r0

  • nodejs Alpine:v3.20

    Plages de versions concernées
    • ECOSYSTEM: < 18.12.1-r0

    Mettez à jour vers 18.12.1-r0

  • nodejs Alpine:v3.21

    Plages de versions concernées
    • ECOSYSTEM: < 18.12.1-r0

    Mettez à jour vers 18.12.1-r0

  • nodejs Alpine:v3.22

    Plages de versions concernées
    • ECOSYSTEM: < 18.12.1-r0

    Mettez à jour vers 18.12.1-r0

  • nodejs Alpine:v3.23

    Plages de versions concernées
    • ECOSYSTEM: < 18.12.1-r0

    Mettez à jour vers 18.12.1-r0

  • nodejs Alpine:v3.24

    Plages de versions concernées
    • ECOSYSTEM: < 18.12.1-r0

    Mettez à jour vers 18.12.1-r0

  • openssl Alpine:v3.17

    Plages de versions concernées
    • ECOSYSTEM: ≥ 3.0.0, < 3.0.7-r0

    Mettez à jour vers 3.0.7-r0

  • openssl Alpine:v3.18

    Plages de versions concernées
    • ECOSYSTEM: ≥ 3.0.0, < 3.0.7-r0

    Mettez à jour vers 3.0.7-r0

  • openssl Alpine:v3.19

    Plages de versions concernées
    • ECOSYSTEM: ≥ 3.0.0, < 3.0.7-r0

    Mettez à jour vers 3.0.7-r0

  • openssl Alpine:v3.20

    Plages de versions concernées
    • ECOSYSTEM: ≥ 3.0.0, < 3.0.7-r0

    Mettez à jour vers 3.0.7-r0

  • openssl Alpine:v3.21

    Plages de versions concernées
    • ECOSYSTEM: ≥ 3.0.0, < 3.0.7-r0

    Mettez à jour vers 3.0.7-r0

  • openssl Alpine:v3.22

    Plages de versions concernées
    • ECOSYSTEM: ≥ 3.0.0, < 3.0.7-r0

    Mettez à jour vers 3.0.7-r0

  • openssl Alpine:v3.23

    Plages de versions concernées
    • ECOSYSTEM: ≥ 3.0.0, < 3.0.7-r0

    Mettez à jour vers 3.0.7-r0

  • openssl Alpine:v3.24

    Plages de versions concernées
    • ECOSYSTEM: ≥ 3.0.0, < 3.0.7-r0

    Mettez à jour vers 3.0.7-r0

  • openssl3 Alpine:v3.15

    Plages de versions concernées
    • ECOSYSTEM: < 3.0.7-r0

    Mettez à jour vers 3.0.7-r0

  • openssl3 Alpine:v3.16

    Plages de versions concernées
    • ECOSYSTEM: < 3.0.7-r0

    Mettez à jour vers 3.0.7-r0

Sources originales

Vérifiez votre serveur →