p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de apache2

Vulnérabilités publiées pour apache2 au cours des 30 derniers jours : 0. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 77

  1. ALPINE-CVE-2024-24795

    Moyenne · CVSS 6.3Correctif disponible

    ALPINE-CVE-2024-24795

    HTTP Response splitting in multiple modules in Apache HTTP Server allows an attacker that can inject malicious response headers into backend applications to cause an HTTP desynchronization attack. Users are recommended to upgrade to version 2.4.59, which fixes this issue.

    • Mettez à jour vers 2.4.59-r0
    Publication Mise à jour
  2. ALPINE-CVE-2023-45802

    Moyenne · CVSS 5.9Correctif disponible

    ALPINE-CVE-2023-45802

    When a HTTP/2 stream was reset (RST frame) by a client, there was a time window were the request's memory resources were not reclaimed immediately. Instead, de-allocation was deferred to connection close. A client could send new requests and resets, keeping the connection busy and open and causing the memory footprint to keep on growing. On connection close, all resources were reclaimed, but the process might run out of memory before that. This was found by the reporter during testing of CVE-2023-44487 (HTTP/2 Rapid Reset Exploit) with their own test client. During "normal" HTTP/2 use, the probability to hit this bug is very low. The kept me

    • Mettez à jour vers 2.4.58-r0
    Publication Mise à jour
  3. ALPINE-CVE-2023-43622

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2023-43622

    An attacker, opening a HTTP/2 connection with an initial window size of 0, was able to block handling of that connection indefinitely in Apache HTTP Server. This could be used to exhaust worker resources in the server, similar to the well known "slow loris" attack pattern. This has been fixed in version 2.4.58, so that such connection are terminated properly after the configured connection timeout. This issue affects Apache HTTP Server: from 2.4.55 through 2.4.57. Users are recommended to upgrade to version 2.4.58, which fixes the issue.

    • Mettez à jour vers 2.4.58-r0
    Publication Mise à jour
  4. ALPINE-CVE-2023-27522

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2023-27522

    HTTP Response Smuggling vulnerability in Apache HTTP Server via mod_proxy_uwsgi. This issue affects Apache HTTP Server: from 2.4.30 through 2.4.55. Special characters in the origin response header can truncate/split the response forwarded to the client.

    • Mettez à jour vers 2.4.56-r0
    Publication Mise à jour
  5. ALPINE-CVE-2023-25690

    Critique · CVSS 9.8Correctif disponible

    ALPINE-CVE-2023-25690

    Some mod_proxy configurations on Apache HTTP Server versions 2.4.0 through 2.4.55 allow a HTTP Request Smuggling attack. Configurations are affected when mod_proxy is enabled along with some form of RewriteRule or ProxyPassMatch in which a non-specific pattern matches some portion of the user-supplied request-target (URL) data and is then re-inserted into the proxied request-target using variable substitution. For example, something like: RewriteEngine on RewriteRule "^/here/(.*)" "http://example.com:8080/elsewhere?$1"; [P] ProxyPassReverse /here/ http://example.com:8080/ Request splitting/smuggling could result in bypass of acc

    • Mettez à jour vers 2.4.56-r0
    Publication Mise à jour
  6. ALPINE-CVE-2022-37436

    Moyenne · CVSS 5.3Correctif disponible

    ALPINE-CVE-2022-37436

    Prior to Apache HTTP Server 2.4.55, a malicious backend can cause the response headers to be truncated early, resulting in some headers being incorporated into the response body. If the later headers have any security purpose, they will not be interpreted by the client.

    • Mettez à jour vers 2.4.55-r0
    Publication Mise à jour
  7. ALPINE-CVE-2022-36760

    Critique · CVSS 9Correctif disponible

    ALPINE-CVE-2022-36760

    Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in mod_proxy_ajp of Apache HTTP Server allows an attacker to smuggle requests to the AJP server it forwards requests to. This issue affects Apache HTTP Server Apache HTTP Server 2.4 version 2.4.54 and prior versions.

    • Mettez à jour vers 2.4.55-r0
    Publication Mise à jour
  8. ALPINE-CVE-2006-20001

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2006-20001

    A carefully crafted If: request header can cause a memory read, or write of a single zero byte, in a pool (heap) memory location beyond the header value sent. This could cause the process to crash. This issue affects Apache HTTP Server 2.4.54 and earlier.

    • Mettez à jour vers 2.4.55-r0
    Publication Mise à jour
  9. ALPINE-CVE-2022-31813

    Critique · CVSS 9.8Correctif disponible

    ALPINE-CVE-2022-31813

    Apache HTTP Server 2.4.53 and earlier may not send the X-Forwarded-* headers to the origin server based on client side Connection header hop-by-hop mechanism. This may be used to bypass IP based authentication on the origin server/application.

    • Mettez à jour vers 2.4.54-r0
    Publication Mise à jour
  10. ALPINE-CVE-2022-28615

    Critique · CVSS 9.1Correctif disponible

    ALPINE-CVE-2022-28615

    Apache HTTP Server 2.4.53 and earlier may crash or disclose information due to a read beyond bounds in ap_strcmp_match() when provided with an extremely large input buffer. While no code distributed with the server can be coerced into such a call, third-party modules or lua scripts that use ap_strcmp_match() may hypothetically be affected.

    • Mettez à jour vers 2.4.54-r0
    Publication Mise à jour
  11. ALPINE-CVE-2022-28614

    Moyenne · CVSS 5.3Correctif disponible

    ALPINE-CVE-2022-28614

    The ap_rwrite() function in Apache HTTP Server 2.4.53 and earlier may read unintended memory if an attacker can cause the server to reflect very large input using ap_rwrite() or ap_rputs(), such as with mod_luas r:puts() function. Modules compiled and distributed separately from Apache HTTP Server that use the 'ap_rputs' function and may pass it a very large (INT_MAX or larger) string must be compiled against current headers to resolve the issue.

    • Mettez à jour vers 2.4.54-r0
    Publication Mise à jour
  12. ALPINE-CVE-2022-26377

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2022-26377

    Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in mod_proxy_ajp of Apache HTTP Server allows an attacker to smuggle requests to the AJP server it forwards requests to. This issue affects Apache HTTP Server Apache HTTP Server 2.4 version 2.4.53 and prior versions.

    • Mettez à jour vers 2.4.54-r0
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →