p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de openssl

Vulnérabilités publiées pour openssl au cours des 30 derniers jours : 0. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 20

  1. ALPINE-CVE-2016-7055

    Moyenne · CVSS 5.9Correctif disponible

    ALPINE-CVE-2016-7055

    There is a carry propagating bug in the Broadwell-specific Montgomery multiplication procedure in OpenSSL 1.0.2 and 1.1.0 before 1.1.0c that handles input lengths divisible by, but longer than 256 bits. Analysis suggests that attacks against RSA, DSA and DH private keys are impossible. This is because the subroutine in question is not used in operations with the private key itself and an input of the attacker's direct choice. Otherwise the bug can manifest itself as transient authentication and key negotiation failures or reproducible erroneous outcome of public-key operations with specially crafted input. Among EC algorithms only Brainpool P

    • Mettez à jour vers 1.0.2k-r0
    Publication Mise à jour
  2. ALPINE-CVE-2017-3732

    Moyenne · CVSS 5.9Correctif disponible

    ALPINE-CVE-2017-3732

    There is a carry propagating bug in the x86_64 Montgomery squaring procedure in OpenSSL 1.0.2 before 1.0.2k and 1.1.0 before 1.1.0d. No EC algorithms are affected. Analysis suggests that attacks against RSA and DSA as a result of this defect would be very difficult to perform and are not believed likely. Attacks against DH are considered just feasible (although very difficult) because most of the work necessary to deduce information about a private key may be performed offline. The amount of resources required for such an attack would be very significant and likely only accessible to a limited number of attackers. An attacker would additional

    • Mettez à jour vers 1.0.2k-r0
    Publication Mise à jour
  3. ALPINE-CVE-2017-3731

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2017-3731

    If an SSL/TLS server or client is running on a 32-bit host, and a specific cipher is being used, then a truncated packet can cause that server or client to perform an out-of-bounds read, usually resulting in a crash. For OpenSSL 1.1.0, the crash can be triggered when using CHACHA20/POLY1305; users should upgrade to 1.1.0d. For Openssl 1.0.2, the crash can be triggered when using RC4-MD5; users who have not disabled that algorithm should update to 1.0.2k.

    • Mettez à jour vers 1.0.2k-r0
    Publication Mise à jour
  4. ALPINE-CVE-2016-6303

    Critique · CVSS 9.8Correctif disponible

    ALPINE-CVE-2016-6303

    Integer overflow in the MDC2_Update function in crypto/mdc2/mdc2dgst.c in OpenSSL before 1.1.0 allows remote attackers to cause a denial of service (out-of-bounds write and application crash) or possibly have unspecified other impact via unknown vectors.

    • Mettez à jour vers 1.0.2h-r3
    Publication Mise à jour
  5. ALPINE-CVE-2016-2182

    Critique · CVSS 9.8Correctif disponible

    ALPINE-CVE-2016-2182

    The BN_bn2dec function in crypto/bn/bn_print.c in OpenSSL before 1.1.0 does not properly validate division results, which allows remote attackers to cause a denial of service (out-of-bounds write and application crash) or possibly have unspecified other impact via unknown vectors.

    • Mettez à jour vers 1.0.2h-r3
    Publication Mise à jour
  6. ALPINE-CVE-2016-2181

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2016-2181

    The Anti-Replay feature in the DTLS implementation in OpenSSL before 1.1.0 mishandles early use of a new epoch number in conjunction with a large sequence number, which allows remote attackers to cause a denial of service (false-positive packet drops) via spoofed DTLS records, related to rec_layer_d1.c and ssl3_record.c.

    • Mettez à jour vers 1.0.2h-r4
    Publication Mise à jour
  7. ALPINE-CVE-2016-2179

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2016-2179

    The DTLS implementation in OpenSSL before 1.1.0 does not properly restrict the lifetime of queue entries associated with unused out-of-order messages, which allows remote attackers to cause a denial of service (memory consumption) by maintaining many crafted DTLS sessions simultaneously, related to d1_lib.c, statem_dtls.c, statem_lib.c, and statem_srvr.c.

    • Mettez à jour vers 1.0.2h-r3
    Publication Mise à jour
  8. ALPINE-CVE-2016-2183

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2016-2183

    The DES and Triple DES ciphers, as used in the TLS, SSH, and IPSec protocols and other protocols and products, have a birthday bound of approximately four billion blocks, which makes it easier for remote attackers to obtain cleartext data via a birthday attack against a long-duration encrypted session, as demonstrated by an HTTPS session using Triple DES in CBC mode, aka a "Sweet32" attack.

    • Mettez à jour vers 1.0.2i-r0
    Publication Mise à jour
  9. ALPINE-CVE-2016-2180

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2016-2180

    The TS_OBJ_print_bio function in crypto/ts/ts_lib.c in the X.509 Public Key Infrastructure Time-Stamp Protocol (TSP) implementation in OpenSSL through 1.0.2h allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted time-stamp file that is mishandled by the "openssl ts" command.

    • Mettez à jour vers 1.0.2h-r2
    Publication Mise à jour
  10. ALPINE-CVE-2016-2177

    Critique · CVSS 9.8Correctif disponible

    ALPINE-CVE-2016-2177

    OpenSSL through 1.0.2h incorrectly uses pointer arithmetic for heap-buffer boundary checks, which might allow remote attackers to cause a denial of service (integer overflow and application crash) or possibly have unspecified other impact by leveraging unexpected malloc behavior, related to s3_srvr.c, ssl_sess.c, and t1_lib.c.

    • Mettez à jour vers 1.0.2h-r1
    Publication Mise à jour
  11. ALPINE-CVE-2016-2176

    Élevée · CVSS 8.2Correctif disponible

    ALPINE-CVE-2016-2176

    The X509_NAME_oneline function in crypto/x509/x509_obj.c in OpenSSL before 1.0.1t and 1.0.2 before 1.0.2h allows remote attackers to obtain sensitive information from process stack memory or cause a denial of service (buffer over-read) via crafted EBCDIC ASN.1 data.

    • Mettez à jour vers 1.0.2h-r0
    Publication Mise à jour
  12. ALPINE-CVE-2016-2107

    Moyenne · CVSS 5.9Correctif disponible

    ALPINE-CVE-2016-2107

    The AES-NI implementation in OpenSSL before 1.0.1t and 1.0.2 before 1.0.2h does not consider memory allocation during a certain padding check, which allows remote attackers to obtain sensitive cleartext information via a padding-oracle attack against an AES CBC session. NOTE: this vulnerability exists because of an incorrect fix for CVE-2013-0169.

    • Mettez à jour vers 1.0.2h-r0
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →