p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de varnish

Vulnérabilités publiées pour varnish au cours des 30 derniers jours : 0. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 12

  1. ALPINE-CVE-2022-45060

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2022-45060

    An HTTP Request Forgery issue was discovered in Varnish Cache 5.x and 6.x before 6.0.11, 7.x before 7.1.2, and 7.2.x before 7.2.1. An attacker may introduce characters through HTTP/2 pseudo-headers that are invalid in the context of an HTTP/1 request line, causing the Varnish server to produce invalid HTTP/1 requests to the backend. This could, in turn, be used to exploit vulnerabilities in a server behind the Varnish server. Note: the 6.0.x LTS series (before 6.0.11) is affected.

    • Mettez à jour vers 7.2.1-r0
    Publication Mise à jour
  2. ALPINE-CVE-2022-45059

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2022-45059

    An issue was discovered in Varnish Cache 7.x before 7.1.2 and 7.2.x before 7.2.1. A request smuggling attack can be performed on Varnish Cache servers by requesting that certain headers are made hop-by-hop, preventing the Varnish Cache servers from forwarding critical headers to the backend.

    • Mettez à jour vers 7.2.1-r0
    Publication Mise à jour
  3. ALPINE-CVE-2022-38150

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2022-38150

    In Varnish Cache 7.0.0, 7.0.1, 7.0.2, and 7.1.0, it is possible to cause the Varnish Server to assert and automatically restart through forged HTTP/1 backend responses. An attack uses a crafted reason phrase of the backend response status line. This is fixed in 7.0.3 and 7.1.1.

    • Mettez à jour vers 7.0.3-r0
    Publication Mise à jour
  4. ALPINE-CVE-2022-23959

    Critique · CVSS 9.1Correctif disponible

    ALPINE-CVE-2022-23959

    In Varnish Cache before 6.6.2 and 7.x before 7.0.2, Varnish Cache 6.0 LTS before 6.0.10, and and Varnish Enterprise (Cache Plus) 4.1.x before 4.1.11r6 and 6.0.x before 6.0.9r4, request smuggling can occur for HTTP/1 connections.

    • Mettez à jour vers 7.0.2-r0
    Publication Mise à jour
  5. ALPINE-CVE-2021-36740

    Moyenne · CVSS 6.5Correctif disponible

    ALPINE-CVE-2021-36740

    Varnish Cache, with HTTP/2 enabled, allows request smuggling and VCL authorization bypass via a large Content-Length header for a POST request. This affects Varnish Enterprise 6.0.x before 6.0.8r3, and Varnish Cache 5.x and 6.x before 6.5.2, 6.6.x before 6.6.1, and 6.0 LTS before 6.0.8.

    • Mettez à jour vers 6.6.1-r0
    Publication Mise à jour
  6. ALPINE-CVE-2019-15892

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2019-15892

    An issue was discovered in Varnish Cache before 6.0.4 LTS, and 6.1.x and 6.2.x before 6.2.1. An HTTP/1 parsing failure allows a remote attacker to trigger an assert by sending crafted HTTP/1 requests. The assert will cause an automatic restart with a clean cache, which makes it a Denial of Service attack.

    • Mettez à jour vers 6.2.1-r0
    Publication Mise à jour
  7. ALPINE-CVE-2017-8807

    Critique · CVSS 9.1Correctif disponible

    ALPINE-CVE-2017-8807

    vbf_stp_error in bin/varnishd/cache/cache_fetch.c in Varnish HTTP Cache 4.1.x before 4.1.9 and 5.x before 5.2.1 allows remote attackers to obtain sensitive information from process memory because a VFP_GetStorage buffer is larger than intended in certain circumstances involving -sfile Stevedore transient objects.

    • Mettez à jour vers 5.2.1-r0
    Publication Mise à jour
  8. ALPINE-CVE-2017-12425

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2017-12425

    An issue was discovered in Varnish HTTP Cache 4.0.1 through 4.0.4, 4.1.0 through 4.1.7, 5.0.0, and 5.1.0 through 5.1.2. A wrong if statement in the varnishd source code means that particular invalid requests from the client can trigger an assert, related to an Integer Overflow. This causes the varnishd worker process to abort and restart, losing the cached contents in the process. An attacker can therefore crash the varnishd worker process on demand and effectively keep it from serving content - a Denial-of-Service attack. The specific source-code filename containing the incorrect statement varies across releases.

    • Mettez à jour vers 5.1.3-r0
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →