p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de apache2

Vulnérabilités publiées pour apache2 au cours des 30 derniers jours : 0. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 17

  1. ALPINE-CVE-2018-11763

    Moyenne · CVSS 5.9Correctif disponible

    ALPINE-CVE-2018-11763

    In Apache HTTP Server 2.4.17 to 2.4.34, by sending continuous, large SETTINGS frames a client can occupy a connection, server thread and CPU time without any connection timeout coming to effect. This affects only HTTP/2 connections. A possible mitigation is to not enable the h2 protocol.

    • Mettez à jour vers 2.4.35-r0
    Publication Mise à jour
  2. ALPINE-CVE-2018-8011

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2018-8011

    By specially crafting HTTP requests, the mod_md challenge handler would dereference a NULL pointer and cause the child process to segfault. This could be used to DoS the server. Fixed in Apache HTTP Server 2.4.34 (Affected 2.4.33).

    • Mettez à jour vers 2.4.34-r0
    Publication Mise à jour
  3. ALPINE-CVE-2018-1312

    Critique · CVSS 9.8Correctif disponible

    ALPINE-CVE-2018-1312

    In Apache httpd 2.2.0 to 2.4.29, when generating an HTTP Digest authentication challenge, the nonce sent to prevent reply attacks was not correctly generated using a pseudo-random seed. In a cluster of servers using a common Digest authentication configuration, HTTP requests could be replayed across servers by an attacker without detection.

    • Mettez à jour vers 2.4.33-r0
    Publication Mise à jour
  4. ALPINE-CVE-2018-1303

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2018-1303

    A specially crafted HTTP request header could have crashed the Apache HTTP Server prior to version 2.4.30 due to an out of bound read while preparing data to be cached in shared memory. It could be used as a Denial of Service attack against users of mod_cache_socache. The vulnerability is considered as low risk since mod_cache_socache is not widely used, mod_cache_disk is not concerned by this vulnerability.

    • Mettez à jour vers 2.4.33-r0
    Publication Mise à jour
  5. ALPINE-CVE-2018-1302

    Moyenne · CVSS 5.9Correctif disponible

    ALPINE-CVE-2018-1302

    When an HTTP/2 stream was destroyed after being handled, the Apache HTTP Server prior to version 2.4.30 could have written a NULL pointer potentially to an already freed memory. The memory pools maintained by the server make this vulnerability hard to trigger in usual configurations, the reporter and the team could not reproduce it outside debug builds, so it is classified as low risk.

    • Mettez à jour vers 2.4.33-r0
    Publication Mise à jour
  6. ALPINE-CVE-2018-1301

    Moyenne · CVSS 5.9Correctif disponible

    ALPINE-CVE-2018-1301

    A specially crafted request could have crashed the Apache HTTP Server prior to version 2.4.30, due to an out of bound access after a size limit is reached by reading the HTTP header. This vulnerability is considered very hard if not impossible to trigger in non-debug mode (both log and build level), so it is classified as low risk for common server usage.

    • Mettez à jour vers 2.4.33-r0
    Publication Mise à jour
  7. ALPINE-CVE-2018-1283

    Moyenne · CVSS 5.3Correctif disponible

    ALPINE-CVE-2018-1283

    In Apache httpd 2.4.0 to 2.4.29, when mod_session is configured to forward its session data to CGI applications (SessionEnv on, not the default), a remote user may influence their content by using a "Session" header. This comes from the "HTTP_SESSION" variable name used by mod_session to forward its data to CGIs, since the prefix "HTTP_" is also used by the Apache HTTP Server to pass HTTP header fields, per CGI specifications.

    • Mettez à jour vers 2.4.33-r0
    Publication Mise à jour
  8. ALPINE-CVE-2017-15715

    Élevée · CVSS 8.1Correctif disponible

    ALPINE-CVE-2017-15715

    In Apache httpd 2.4.0 to 2.4.29, the expression specified in <FilesMatch> could match '$' to a newline character in a malicious filename, rather than matching only the end of the filename. This could be exploited in environments where uploads of some files are are externally blocked, but only by matching the trailing portion of the filename.

    • Mettez à jour vers 2.4.33-r0
    Publication Mise à jour
  9. ALPINE-CVE-2017-15710

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2017-15710

    In Apache httpd 2.0.23 to 2.0.65, 2.2.0 to 2.2.34, and 2.4.0 to 2.4.29, mod_authnz_ldap, if configured with AuthLDAPCharsetConfig, uses the Accept-Language header value to lookup the right charset encoding when verifying the user's credentials. If the header value is not present in the charset conversion table, a fallback mechanism is used to truncate it to a two characters value to allow a quick retry (for example, 'en-US' is truncated to 'en'). A header value of less than two characters forces an out of bound write of one NUL byte to a memory location that is not part of the string. In the worst case, quite unlikely, the process would crash

    • Mettez à jour vers 2.4.33-r0
    Publication Mise à jour
  10. ALPINE-CVE-2017-9798

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2017-9798

    Apache httpd allows remote attackers to read secret data from process memory if the Limit directive can be set in a user's .htaccess file, or if httpd.conf has certain misconfigurations, aka Optionsbleed. This affects the Apache HTTP Server through 2.2.34 and 2.4.x through 2.4.27. The attacker sends an unauthenticated OPTIONS HTTP request when attempting to read secret data. This is a use-after-free issue and thus secret data is not always sent, and the specific data depends on many factors including configuration. Exploitation with .htaccess can be blocked with a patch to the ap_limit_section function in server/core.c.

    • Mettez à jour vers 2.4.27-r1
    Publication Mise à jour
  11. ALPINE-CVE-2017-7668

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2017-7668

    The HTTP strict parsing changes added in Apache httpd 2.2.32 and 2.4.24 introduced a bug in token list parsing, which allows ap_find_token() to search past the end of its input string. By maliciously crafting a sequence of request headers, an attacker may be able to cause a segmentation fault, or to force ap_find_token() to return an incorrect value.

    • Mettez à jour vers 2.4.26-r0
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →