p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de curl

Vulnérabilité publiée pour curl au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 41

  1. ALPINE-CVE-2018-16840

    Critique · CVSS 9.8Correctif disponible

    ALPINE-CVE-2018-16840

    A heap use-after-free flaw was found in curl versions from 7.59.0 through 7.61.1 in the code related to closing an easy handle. When closing and cleaning up an 'easy' handle in the `Curl_close()` function, the library code first frees a struct (without nulling the pointer) and might then subsequently erroneously write to a struct field within that already freed struct.

    • Mettez à jour vers 7.61.1-r1
    Publication Mise à jour
  2. ALPINE-CVE-2018-14618

    Critique · CVSS 9.8Correctif disponible

    ALPINE-CVE-2018-14618

    curl before version 7.61.1 is vulnerable to a buffer overrun in the NTLM authentication code. The internal function Curl_ntlm_core_mk_nt_hash multiplies the length of the password by two (SUM) to figure out how large temporary storage area to allocate from the heap. The length value is then subsequently used to iterate over the password and generate output into the allocated storage buffer. On systems with a 32 bit size_t, the math to calculate SUM triggers an integer overflow when the password length exceeds 2GB (2^31 bytes). This integer overflow usually causes a very small buffer to actually get allocated instead of the intended very huge

    • Mettez à jour vers 7.61.1-r0
    Publication Mise à jour
  3. ALPINE-CVE-2016-8616

    Moyenne · CVSS 5.9Correctif disponible

    ALPINE-CVE-2016-8616

    A flaw was found in curl before version 7.51.0 When re-using a connection, curl was doing case insensitive comparisons of user name and password with the existing connections. This means that if an unused connection with proper credentials exists for a protocol that has connection-scoped credentials, an attacker can cause that connection to be reused if s/he knows the case-insensitive version of the correct password.

    • Mettez à jour vers 7.51.0-r0
    Publication Mise à jour
  4. ALPINE-CVE-2016-8615

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2016-8615

    A flaw was found in curl before version 7.51. If cookie state is written into a cookie jar file that is later read back and used for subsequent requests, a malicious HTTP server can inject new cookies for arbitrary domains into said cookie jar.

    • Mettez à jour vers 7.51.0-r0
    Publication Mise à jour
  5. ALPINE-CVE-2016-8624

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2016-8624

    curl before version 7.51.0 doesn't parse the authority component of the URL correctly when the host name part ends with a '#' character, and could instead be tricked into connecting to a different host. This may have security implications if you for example use an URL parser that follows the RFC to check for allowed domains before using curl to request them.

    • Mettez à jour vers 7.51.0-r0
    Publication Mise à jour
  6. ALPINE-CVE-2016-8622

    Critique · CVSS 9.8Correctif disponible

    ALPINE-CVE-2016-8622

    The URL percent-encoding decode function in libcurl before 7.51.0 is called `curl_easy_unescape`. Internally, even if this function would be made to allocate a unscape destination buffer larger than 2GB, it would return that new length in a signed 32 bit integer variable, thus the length would get either just truncated or both truncated and turned negative. That could then lead to libcurl writing outside of its heap based buffer.

    • Mettez à jour vers 7.51.0-r0
    Publication Mise à jour
  7. ALPINE-CVE-2017-2629

    Moyenne · CVSS 6.5Correctif disponible

    ALPINE-CVE-2017-2629

    curl before 7.53.0 has an incorrect TLS Certificate Status Request extension feature that asks for a fresh proof of the server's certificate's validity in the code that checks for a test success or failure. It ends up always thinking there's valid proof, even when there is none or if the server doesn't support the TLS extension in question. This could lead to users not detecting when a server's certificate goes invalid or otherwise be mislead that the server is in a better shape than it is in reality. This flaw also exists in the command line tool (--cert-status).

    • Mettez à jour vers 7.52.1-r2
    Publication Mise à jour
  8. ALPINE-CVE-2017-7468

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2017-7468

    In curl and libcurl 7.52.0 to and including 7.53.1, libcurl would attempt to resume a TLS session even if the client certificate had changed. That is unacceptable since a server by specification is allowed to skip the client certificate check on resume, and may instead use the old identity which was established by the previous certificate (or no certificate). libcurl supports by default the use of TLS session id/ticket to resume previous TLS sessions to speed up subsequent TLS handshakes. They are used when for any reason an existing TLS connection couldn't be kept alive to make the next handshake faster. This flaw is a regression and identic

    • Mettez à jour vers 7.52.1-r3
    Publication Mise à jour
  9. ALPINE-CVE-2018-0500

    Critique · CVSS 9.8Correctif disponible

    ALPINE-CVE-2018-0500

    Curl_smtp_escape_eob in lib/smtp.c in curl 7.54.1 to and including curl 7.60.0 has a heap-based buffer overflow that might be exploitable by an attacker who can control the data that curl transmits over SMTP with certain settings (i.e., use of a nonstandard --limit-rate argument or CURLOPT_BUFFERSIZE value).

    • Mettez à jour vers 7.61.0-r0
    Publication Mise à jour
  10. ALPINE-CVE-2018-1000301

    Critique · CVSS 9.1Correctif disponible

    ALPINE-CVE-2018-1000301

    curl version curl 7.20.0 to and including curl 7.59.0 contains a CWE-126: Buffer Over-read vulnerability in denial of service that can result in curl can be tricked into reading data beyond the end of a heap based buffer used to store downloaded RTSP content.. This vulnerability appears to have been fixed in curl < 7.20.0 and curl >= 7.60.0.

    • Mettez à jour vers 7.60.0-r0
    Publication Mise à jour
  11. ALPINE-CVE-2018-1000300

    Critique · CVSS 9.8Correctif disponible

    ALPINE-CVE-2018-1000300

    curl version curl 7.54.1 to and including curl 7.59.0 contains a CWE-122: Heap-based Buffer Overflow vulnerability in denial of service and more that can result in curl might overflow a heap based memory buffer when closing down an FTP connection with very long server command replies.. This vulnerability appears to have been fixed in curl < 7.54.1 and curl >= 7.60.0.

    • Mettez à jour vers 7.60.0-r0
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →