ALSA-2023:4644
ALSA-2023:4644 · Important: .NET 6.0 security, bug fix, and enhancement update
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
.NET is a managed-software framework. It implements a subset of the .NET framework APIs and several new APIs, and it includes a CLR implementation. New versions of .NET that address a security vulnerability are now available. The updated versions are .NET SDK 6.0.121 and .NET Runtime 6.0.21. Security Fix(es): * dotnet: RCE under dotnet commands (CVE-2023-35390) * dotnet: Kestrel vulnerability to slow read attacks leading to Denial of Service attack (CVE-2023-38180) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
aspnetcore-runtime-6.0 AlmaLinux:9
- Plages de versions concernées
- ECOSYSTEM: < 6.0.21-1.el9_2
Mettez à jour vers 6.0.21-1.el9_2
aspnetcore-targeting-pack-6.0 AlmaLinux:9
- Plages de versions concernées
- ECOSYSTEM: < 6.0.21-1.el9_2
Mettez à jour vers 6.0.21-1.el9_2
dotnet-apphost-pack-6.0 AlmaLinux:9
- Plages de versions concernées
- ECOSYSTEM: < 6.0.21-1.el9_2
Mettez à jour vers 6.0.21-1.el9_2
dotnet-hostfxr-6.0 AlmaLinux:9
- Plages de versions concernées
- ECOSYSTEM: < 6.0.21-1.el9_2
Mettez à jour vers 6.0.21-1.el9_2
dotnet-runtime-6.0 AlmaLinux:9
- Plages de versions concernées
- ECOSYSTEM: < 6.0.21-1.el9_2
Mettez à jour vers 6.0.21-1.el9_2
dotnet-sdk-6.0 AlmaLinux:9
- Plages de versions concernées
- ECOSYSTEM: < 6.0.121-1.el9_2
Mettez à jour vers 6.0.121-1.el9_2
dotnet-sdk-6.0-source-built-artifacts AlmaLinux:9
- Plages de versions concernées
- ECOSYSTEM: < 6.0.121-1.el9_2
Mettez à jour vers 6.0.121-1.el9_2
dotnet-targeting-pack-6.0 AlmaLinux:9
- Plages de versions concernées
- ECOSYSTEM: < 6.0.21-1.el9_2
Mettez à jour vers 6.0.21-1.el9_2
dotnet-templates-6.0 AlmaLinux:9
- Plages de versions concernées
- ECOSYSTEM: < 6.0.121-1.el9_2
Mettez à jour vers 6.0.121-1.el9_2
Sources originales
- https://access.redhat.com/errata/RHSA-2023:4644
- https://access.redhat.com/security/cve/CVE-2023-35390
- https://access.redhat.com/security/cve/CVE-2023-38180
- https://bugzilla.redhat.com/2228621
- https://bugzilla.redhat.com/2228622
- https://errata.almalinux.org/9/ALSA-2023-4644.html
- https://osv.dev/vulnerability/ALSA-2023:4644