ALSA-2024:0806
ALSA-2024:0806 · Important: dotnet7.0 security update
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
.NET is a managed-software framework. It implements a subset of the .NET framework APIs and several new APIs, and it includes a CLR implementation. New versions of .NET that address a security vulnerability are now available. The updated versions are .NET SDK 7.0.116 and .NET Runtime 7.0.16. Security Fix(es): * dotnet: Denial of Service in SignalR server (CVE-2024-21386) * dotnet: Denial of Service in X509Certificate2 (CVE-2024-21404) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
aspnetcore-runtime-7.0 AlmaLinux:8
- Plages de versions concernées
- ECOSYSTEM: < 7.0.16-1.el8_9
Mettez à jour vers 7.0.16-1.el8_9
aspnetcore-targeting-pack-7.0 AlmaLinux:8
- Plages de versions concernées
- ECOSYSTEM: < 7.0.16-1.el8_9
Mettez à jour vers 7.0.16-1.el8_9
dotnet-apphost-pack-7.0 AlmaLinux:8
- Plages de versions concernées
- ECOSYSTEM: < 7.0.16-1.el8_9
Mettez à jour vers 7.0.16-1.el8_9
dotnet-hostfxr-7.0 AlmaLinux:8
- Plages de versions concernées
- ECOSYSTEM: < 7.0.16-1.el8_9
Mettez à jour vers 7.0.16-1.el8_9
dotnet-runtime-7.0 AlmaLinux:8
- Plages de versions concernées
- ECOSYSTEM: < 7.0.16-1.el8_9
Mettez à jour vers 7.0.16-1.el8_9
dotnet-sdk-7.0 AlmaLinux:8
- Plages de versions concernées
- ECOSYSTEM: < 7.0.116-1.el8_9
Mettez à jour vers 7.0.116-1.el8_9
dotnet-sdk-7.0-source-built-artifacts AlmaLinux:8
- Plages de versions concernées
- ECOSYSTEM: < 7.0.116-1.el8_9
Mettez à jour vers 7.0.116-1.el8_9
dotnet-targeting-pack-7.0 AlmaLinux:8
- Plages de versions concernées
- ECOSYSTEM: < 7.0.16-1.el8_9
Mettez à jour vers 7.0.16-1.el8_9
dotnet-templates-7.0 AlmaLinux:8
- Plages de versions concernées
- ECOSYSTEM: < 7.0.116-1.el8_9
Mettez à jour vers 7.0.116-1.el8_9
Sources originales
- https://access.redhat.com/errata/RHSA-2024:0806
- https://access.redhat.com/security/cve/CVE-2024-21386
- https://access.redhat.com/security/cve/CVE-2024-21404
- https://bugzilla.redhat.com/2263085
- https://bugzilla.redhat.com/2263086
- https://errata.almalinux.org/8/ALSA-2024-0806.html
- https://osv.dev/vulnerability/ALSA-2024:0806