p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de deepseek-tui-cli

Vulnérabilité publiée pour deepseek-tui-cli au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 2

  1. CVE-2026-45311

    Critique · CVSS 9.6EPSS 0,57%Correctif disponible

    CodeWhale: run_tests Tool Enables RCE via Malicious Repository Without Approval

    CodeWhale is a DeepSeek + MiMo coding agent in terminal. From 0.3.0 to 0.8.23, the run_tests tool executes cargo test in the workspace with ApprovalRequirement::Auto, meaning it runs without any user approval prompt. cargo test compiles and executes arbitrary code: test binaries, build.rs build scripts, and proc macros. While auto-approving test execution is a deliberate design choice, it creates an inconsistency in the security boundary. However, in a malicious repository, test code can execute arbitrary shell commands, exfiltrate credentials, or establish persistence with zero approval. The attack is amplified by AGENTS.md (auto-loaded into

    • Mettez à jour vers 0.8.23
    Publication Mise à jour
  2. CVE-2026-45310

    Élevée · CVSS 7.4EPSS 0,28%Correctif disponible

    CodeWhale: SSRF via HTTP Redirect Bypass in fetch_url Tool

    CodeWhale is a DeepSeek + MiMo coding agent in terminal. Prior to 0.8.22, the fetch_url tool validates the initial URL's resolved IP address against a restricted-IP blocklist (is_restricted_ip()) to prevent SSRF attacks against internal services (cloud metadata endpoints, localhost, private networks). However, the HTTP client (reqwest) is configured to automatically follow up to 5 redirects (reqwest::redirect::Policy::limited(5)) without re-validating the redirect target against the same SSRF protections. This vulnerability is fixed in 0.8.22.

    • Mettez à jour vers 0.8.22
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →