CVE-2019-10161
CVE-2019-10161
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
It was discovered that libvirtd before versions 4.10.1 and 5.4.1 would permit read-only clients to use the virDomainSaveImageGetXMLDesc() API, specifying an arbitrary path which would be accessed with the permissions of the libvirtd process. An attacker with access to the libvirtd socket could use this to probe the existence of arbitrary files, cause denial of service or cause libvirtd to execute arbitrary programs.
CVSS 8.8 · Élevée · EPSS 0,5% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
libvirt
- Versions du logiciel
- fixed in 4.10.1: Concernée
- fixed in 5.4.1: Concernée
Aucun correctif publié
libvirt Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 5.0.0-4
Mettez à jour vers 5.0.0-4
libvirt Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 5.0.0-4
Mettez à jour vers 5.0.0-4
libvirt Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 5.0.0-4
Mettez à jour vers 5.0.0-4
libvirt Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 1.1.1-0ubuntu8
- 1.1.1-0ubuntu9
- 1.1.4-0ubuntu2
- 1.1.4-0ubuntu3
- 1.1.4-0ubuntu4
- 1.1.4-0ubuntu5
- 1.2.0-0ubuntu1
- 1.2.0-0ubuntu2
- 1.2.0-0ubuntu3
- 1.2.1-0ubuntu1
- 1.2.1-0ubuntu2
- 1.2.1-0ubuntu3
- 1.2.1-0ubuntu4
- 1.2.1-0ubuntu5
- 1.2.1-0ubuntu7
- 1.2.1-0ubuntu8
- 1.2.1-0ubuntu9
- 1.2.1-0ubuntu10
- 1.2.2-0ubuntu1
- 1.2.2-0ubuntu2
- 1.2.2-0ubuntu3
- 1.2.2-0ubuntu4
- 1.2.2-0ubuntu5
- 1.2.2-0ubuntu6
- 1.2.2-0ubuntu7
- 1.2.2-0ubuntu8
- 1.2.2-0ubuntu9
- 1.2.2-0ubuntu10
- 1.2.2-0ubuntu11
- 1.2.2-0ubuntu12
- 1.2.2-0ubuntu13
- 1.2.2-0ubuntu13.1
- 1.2.2-0ubuntu13.1.1
- 1.2.2-0ubuntu13.1.2
- 1.2.2-0ubuntu13.1.4
- 1.2.2-0ubuntu13.1.5
- 1.2.2-0ubuntu13.1.6
- 1.2.2-0ubuntu13.1.7
- 1.2.2-0ubuntu13.1.8
- 1.2.2-0ubuntu13.1.9
- 1.2.2-0ubuntu13.1.10
- 1.2.2-0ubuntu13.1.12
- 1.2.2-0ubuntu13.1.14
- 1.2.2-0ubuntu13.1.16
- 1.2.2-0ubuntu13.1.17
- 1.2.2-0ubuntu13.1.20
- 1.2.2-0ubuntu13.1.21
- 1.2.2-0ubuntu13.1.22
- 1.2.2-0ubuntu13.1.23
- 1.2.2-0ubuntu13.1.25
- 1.2.2-0ubuntu13.1.26
- 1.2.2-0ubuntu13.1.27
- 1.2.2-0ubuntu13.1.28
- Plages de versions concernées
- ECOSYSTEM: < 1.2.2-0ubuntu13.1.28+esm1
Mettez à jour vers 1.2.2-0ubuntu13.1.28+esm1
libvirt Ubuntu:16.04:LTS
- Versions du logiciel
- 1.2.16-2ubuntu11
- 1.2.16-2ubuntu12
- 1.2.16-2ubuntu13
- 1.2.16-2ubuntu14
- 1.2.21-2ubuntu1
- 1.2.21-2ubuntu3
- 1.2.21-2ubuntu4
- 1.2.21-2ubuntu5
- 1.2.21-2ubuntu7
- 1.2.21-2ubuntu8
- 1.2.21-2ubuntu9
- 1.2.21-2ubuntu10
- 1.3.1-1ubuntu1
- 1.3.1-1ubuntu2
- 1.3.1-1ubuntu3
- 1.3.1-1ubuntu4
- 1.3.1-1ubuntu6
- 1.3.1-1ubuntu9
- 1.3.1-1ubuntu10
- 1.3.1-1ubuntu10.1
- 1.3.1-1ubuntu10.2
- 1.3.1-1ubuntu10.3
- 1.3.1-1ubuntu10.5
- 1.3.1-1ubuntu10.6
- 1.3.1-1ubuntu10.7
- 1.3.1-1ubuntu10.8
- 1.3.1-1ubuntu10.10
- 1.3.1-1ubuntu10.11
- 1.3.1-1ubuntu10.12
- 1.3.1-1ubuntu10.13
- 1.3.1-1ubuntu10.14
- 1.3.1-1ubuntu10.15
- 1.3.1-1ubuntu10.17
- 1.3.1-1ubuntu10.18
- 1.3.1-1ubuntu10.19
- 1.3.1-1ubuntu10.21
- 1.3.1-1ubuntu10.22
- 1.3.1-1ubuntu10.23
- 1.3.1-1ubuntu10.24
- 1.3.1-1ubuntu10.25
- 1.3.1-1ubuntu10.26
- Plages de versions concernées
- ECOSYSTEM: < 1.3.1-1ubuntu10.27
Mettez à jour vers 1.3.1-1ubuntu10.27
libvirt Ubuntu:18.04:LTS
- Versions du logiciel
- 3.6.0-1ubuntu5
- 3.6.0-1ubuntu6
- 4.0.0-1ubuntu1
- 4.0.0-1ubuntu2
- 4.0.0-1ubuntu3
- 4.0.0-1ubuntu4
- 4.0.0-1ubuntu5
- 4.0.0-1ubuntu6
- 4.0.0-1ubuntu7
- 4.0.0-1ubuntu8
- 4.0.0-1ubuntu8.1
- 4.0.0-1ubuntu8.2
- 4.0.0-1ubuntu8.3
- 4.0.0-1ubuntu8.4
- 4.0.0-1ubuntu8.5
- 4.0.0-1ubuntu8.6
- 4.0.0-1ubuntu8.7
- 4.0.0-1ubuntu8.8
- 4.0.0-1ubuntu8.9
- 4.0.0-1ubuntu8.10
- 4.0.0-1ubuntu8.11
- Plages de versions concernées
- ECOSYSTEM: < 4.0.0-1ubuntu8.12
Mettez à jour vers 4.0.0-1ubuntu8.12
Sources originales
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10161
- https://access.redhat.com/libvirt-privesc-vulnerabilities
- https://libvirt.org/git/?p=libvirt.git%3Ba=commit%3Bh=aed6a032cead4386472afb24b16196579e239580
- https://usn.ubuntu.com/4047-2/
- https://security.gentoo.org/glsa/202003-18
- https://nvd.nist.gov/vuln/detail/CVE-2019-10161