CVE-2019-16786
CVE-2019-16786 · HTTP Request Smuggling: Invalid Transfer-Encoding in Waitress
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Waitress through version 1.3.1 would parse the Transfer-Encoding header and only look for a single string value, if that value was not chunked it would fall through and use the Content-Length header instead. According to the HTTP standard Transfer-Encoding should be a comma separated list, with the inner-most encoding first, followed by any further transfer codings, ending with chunked. Requests sent with: "Transfer-Encoding: gzip, chunked" would incorrectly get ignored, and the request would use a Content-Length header instead to determine the body size of the HTTP message. This could allow for Waitress to treat a single request as multiple requests in the case of HTTP pipelining. This issue is fixed in Waitress 1.4.0.
CVSS 7.1 · Élevée · EPSS 2,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · python
Produits et versions concernés
waitress
- Versions du logiciel
- ≥ <= 1.3.1, ≤ 1.3.1: Concernée (custom)
Aucun correctif publié
waitress Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 1.4.1-1
Mettez à jour vers 1.4.1-1
waitress Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 1.4.1-1
Mettez à jour vers 1.4.1-1
waitress Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 1.4.1-1
Mettez à jour vers 1.4.1-1
waitress PyPI
- Versions du logiciel
- 0.1
- 0.2
- 0.3
- 0.4
- 0.5
- 0.6
- 0.6.1
- 0.7
- 0.8
- 0.8.1
- 0.8.10
- 0.8.11b0
- 0.8.2
- 0.8.3
- 0.8.4
- 0.8.5
- 0.8.6
- 0.8.7
- 0.8.8
- 0.8.9
- 0.9.0
- 0.9.0b0
- 0.9.0b1
- 1.0.0
- 1.0.1
- 1.0.2
- 1.0a1
- 1.0a2
- 1.1.0
- 1.2.0
- 1.2.0b1
- 1.2.0b2
- 1.2.0b3
- 1.2.1
- 1.3.0
- 1.3.0b0
- 1.3.1
- Plages de versions concernées
- ECOSYSTEM: < 1.4.0
Mettez à jour vers 1.4.0
waitress PyPI
- Versions du logiciel
- 0.1
- 0.2
- 0.3
- 0.4
- 0.5
- 0.6
- 0.6.1
- 0.7
- 0.8
- 0.8.1
- 0.8.2
- 0.8.3
- 0.8.4
- 0.8.5
- 0.8.6
- 0.8.7
- 0.8.8
- 0.8.9
- 0.8.10
- 0.8.11b0
- 0.9.0b0
- 0.9.0b1
- 0.9.0
- 1.0a1
- 1.0a2
- 1.0.0
- 1.0.1
- 1.0.2
- 1.1.0
- 1.2.0b1
- 1.2.0b2
- 1.2.0b3
- 1.2.0
- 1.2.1
- 1.3.0b0
- 1.3.0
- Plages de versions concernées
- GIT: < f11093a6b3240fc26830b6111e826128af7771c3
- ECOSYSTEM: < 1.3.1
Mettez à jour vers 1.3.1
waitress Ubuntu:16.04:LTS
- Versions du logiciel
- 0.8.9-2ubuntu1
- 0.8.10-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
waitress Ubuntu:18.04:LTS
- Versions du logiciel
- 1.0.1-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GVDHR2DNKCNQ7YQXISJ45NT4IQDX3LJ7/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LYEOTGWJZVKPRXX2HBNVIYWCX73QYPM5/
- https://access.redhat.com/errata/RHSA-2020:0720
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://docs.pylonsproject.org/projects/waitress/en/latest/#security-fixes
- https://github.com/Pylons/waitress/security/advisories/GHSA-g2xc-35jw-c63p
- https://github.com/Pylons/waitress/commit/f11093a6b3240fc26830b6111e826128af7771c3
- https://lists.debian.org/debian-lts-announce/2022/05/msg00011.html
- https://nvd.nist.gov/vuln/detail/CVE-2019-16786