CVE-2019-16789
CVE-2019-16789 · HTTP Request Smuggling in Waitress: Invalid whitespace characters in headers
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
In Waitress through version 1.4.0, if a proxy server is used in front of waitress, an invalid request may be sent by an attacker that bypasses the front-end and is parsed differently by waitress leading to a potential for HTTP request smuggling. Specially crafted requests containing special whitespace characters in the Transfer-Encoding header would get parsed by Waitress as being a chunked request, but a front-end server would use the Content-Length instead as the Transfer-Encoding header is considered invalid due to containing invalid characters. If a front-end server does HTTP pipelining to a backend Waitress server this could lead to HTTP request splitting which may lead to potential cache poisoning or unexpected information disclosure. This issue is fixed in Waitress 1.4.1 through more strict HTTP field validation.
CVSS 7.1 · Élevée · EPSS 2,6% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · python
Produits et versions concernés
waitress
- Versions du logiciel
- ≥ < 1.4.1, < 1.4.1: Concernée (custom)
Aucun correctif publié
waitress Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 1.4.1-1
Mettez à jour vers 1.4.1-1
waitress Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 1.4.1-1
Mettez à jour vers 1.4.1-1
waitress Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 1.4.1-1
Mettez à jour vers 1.4.1-1
waitress PyPI
- Versions du logiciel
- 0.1
- 0.2
- 0.3
- 0.4
- 0.5
- 0.6
- 0.6.1
- 0.7
- 0.8
- 0.8.1
- 0.8.10
- 0.8.11b0
- 0.8.2
- 0.8.3
- 0.8.4
- 0.8.5
- 0.8.6
- 0.8.7
- 0.8.8
- 0.8.9
- 0.9.0
- 0.9.0b0
- 0.9.0b1
- 1.0.0
- 1.0.1
- 1.0.2
- 1.0a1
- 1.0a2
- 1.1.0
- 1.2.0
- 1.2.0b1
- 1.2.0b2
- 1.2.0b3
- 1.2.1
- 1.3.0
- 1.3.0b0
- 1.3.1
- 1.4.0
- 1.4.1
- Plages de versions concernées
- ECOSYSTEM: < 1.4.2
Mettez à jour vers 1.4.2
waitress PyPI
- Versions du logiciel
- 0.1
- 0.2
- 0.3
- 0.4
- 0.5
- 0.6
- 0.6.1
- 0.7
- 0.8
- 0.8.1
- 0.8.2
- 0.8.3
- 0.8.4
- 0.8.5
- 0.8.6
- 0.8.7
- 0.8.8
- 0.8.9
- 0.8.10
- 0.8.11b0
- 0.9.0b0
- 0.9.0b1
- 0.9.0
- 1.0a1
- 1.0a2
- 1.0.0
- 1.0.1
- 1.0.2
- 1.1.0
- 1.2.0b1
- 1.2.0b2
- 1.2.0b3
- 1.2.0
- 1.2.1
- 1.3.0b0
- 1.3.0
- 1.3.1
- 1.4.0
- Plages de versions concernées
- GIT: < 11d9e138125ad46e951027184b13242a3c1de017
- ECOSYSTEM: < 1.4.1
Mettez à jour vers 1.4.1
waitress Ubuntu:16.04:LTS
- Versions du logiciel
- 0.8.9-2ubuntu1
- 0.8.10-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
waitress Ubuntu:18.04:LTS
- Versions du logiciel
- 1.0.1-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GVDHR2DNKCNQ7YQXISJ45NT4IQDX3LJ7/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LYEOTGWJZVKPRXX2HBNVIYWCX73QYPM5/
- https://access.redhat.com/errata/RHSA-2020:0720
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://docs.pylonsproject.org/projects/waitress/en/latest/#security-fixes
- https://github.com/github/advisory-review/pull/14604
- https://github.com/Pylons/waitress/commit/11d9e138125ad46e951027184b13242a3c1de017
- https://lists.debian.org/debian-lts-announce/2022/05/msg00011.html
- https://nvd.nist.gov/vuln/detail/CVE-2019-16789