CVE-2019-9636
CVE-2019-9636
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Cette page présente une partie des faits des sources. Consultez les avis liés pour la description complète et les versions concernées.
Python 2.7.x through 2.7.16 and 3.x through 3.7.2 is affected by: Improper Handling of Unicode Encoding (with an incorrect netloc) during NFKC normalization. The impact is: Information disclosure (credentials, cookies, etc. that are cached against a given hostname). The components are: urllib.parse.urlsplit, urllib.parse.urlparse. The attack vector is: A specially crafted URL could be incorrectly parsed to locate cookies or authentication data and send that information to a different host than when parsed correctly. This is fixed in: v2.7.17, v2.7.17rc1, v2.7.18, v2.7.18rc1; v3.5.10, v3.5.10rc1, v3.5.7, v3.5.8, v3.5.8rc1, v3.5.8rc2, v3.5.9; v3.6.10, v3.6.10rc1, v3.6.11, v3.6.11rc1, v3.6.12, v3.6.9, v3.6.9rc1; v3.7.3, v3.7.3rc1, v3.7.4, v3.7.4rc1, v3.7.4rc2, v3.7.5, v3.7.5rc1, v3.7.6, v3.7.6rc1, v3.7.7, v3.7.7rc1, v3.7.8, v3.7.8rc1, v3.7.9.
CVSS 5.3 · Moyenne · EPSS 7,7% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
n/a
- Versions du logiciel
- n/a: Concernée
Aucun correctif publié
python2.7 Debian:11
- Plages de versions concernées
- ECOSYSTEM: < 2.7.16-2
Mettez à jour vers 2.7.16-2
python2.7 Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 2.7.5-8ubuntu3
- 2.7.5-8ubuntu4
- 2.7.6-2
- 2.7.6-2ubuntu1
- 2.7.6-3
- 2.7.6-3ubuntu1
- 2.7.6-4
- 2.7.6-4ubuntu1
- 2.7.6-5
- 2.7.6-7
- 2.7.6-8
- 2.7.6-8ubuntu0.2
- 2.7.6-8ubuntu0.3
- 2.7.6-8ubuntu0.4
- 2.7.6-8ubuntu0.5
- Plages de versions concernées
- ECOSYSTEM: < 2.7.6-8ubuntu0.6+esm2
Mettez à jour vers 2.7.6-8ubuntu0.6+esm2
python3.4 Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 3.4~b1-0ubuntu3
- 3.4~b1-4ubuntu4
- 3.4~b1-4ubuntu6
- 3.4~b1-5ubuntu2
- 3.4~b2-1
- 3.4~b3-1ubuntu1
- 3.4~rc1-1build1
- 3.4~rc2-1
- 3.4~rc3-0ubuntu1
- 3.4.0-1
- 3.4.0-2ubuntu1
- 3.4.0-2ubuntu1.1
- 3.4.3-1ubuntu1~14.04.1
- 3.4.3-1ubuntu1~14.04.3
- 3.4.3-1ubuntu1~14.04.4
- 3.4.3-1ubuntu1~14.04.5
- 3.4.3-1ubuntu1~14.04.6
- 3.4.3-1ubuntu1~14.04.7
- Plages de versions concernées
- ECOSYSTEM: < 3.4.3-1ubuntu1~14.04.7+esm2
Mettez à jour vers 3.4.3-1ubuntu1~14.04.7+esm2
python3.5 Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 3.5.2-2ubuntu0~16.04.4~14.04.1
- Plages de versions concernées
- ECOSYSTEM: < 3.5.2-2ubuntu0~16.04.4~14.04.1+esm1
Mettez à jour vers 3.5.2-2ubuntu0~16.04.4~14.04.1+esm1
python2.7 Ubuntu:16.04:LTS
- Versions du logiciel
- 2.7.10-4ubuntu1
- 2.7.10-4ubuntu2
- 2.7.11-2
- 2.7.11-3
- 2.7.11-4
- 2.7.11-6
- 2.7.11-7
- 2.7.11-7ubuntu1
- 2.7.12-1~16.04
- 2.7.12-1ubuntu0~16.04.1
- 2.7.12-1ubuntu0~16.04.2
- 2.7.12-1ubuntu0~16.04.3
- 2.7.12-1ubuntu0~16.04.4
- Plages de versions concernées
- ECOSYSTEM: < 2.7.12-1ubuntu0~16.04.8
Mettez à jour vers 2.7.12-1ubuntu0~16.04.8
python3.5 Ubuntu:16.04:LTS
- Versions du logiciel
- 3.5.0-3
- 3.5.0-3ubuntu1
- 3.5.1~rc1-2ubuntu1
- 3.5.1-1
- 3.5.1-2
- 3.5.1-3
- 3.5.1-5
- 3.5.1-6ubuntu1
- 3.5.1-6ubuntu2
- 3.5.1-9ubuntu1
- 3.5.1-10
- 3.5.2-2~16.01
- 3.5.2-2~16.04
- 3.5.2-2ubuntu0~16.04.1
- 3.5.2-2ubuntu0~16.04.2
- 3.5.2-2ubuntu0~16.04.3
- 3.5.2-2ubuntu0~16.04.4
- 3.5.2-2ubuntu0~16.04.5
- Plages de versions concernées
- ECOSYSTEM: < 3.5.2-2ubuntu0~16.04.8
Mettez à jour vers 3.5.2-2ubuntu0~16.04.8
python2.7 Ubuntu:18.04:LTS
- Versions du logiciel
- 2.7.14-2ubuntu2
- 2.7.14-4
- 2.7.14-6
- 2.7.14-7
- 2.7.14-8
- 2.7.15~rc1-1
- 2.7.15~rc1-1ubuntu0.1
- 2.7.15-4ubuntu4~18.04
- Plages de versions concernées
- ECOSYSTEM: < 2.7.15-4ubuntu4~18.04.1
Mettez à jour vers 2.7.15-4ubuntu4~18.04.1
python3.6 Ubuntu:18.04:LTS
- Versions du logiciel
- 3.6.3-1ubuntu1
- 3.6.4~rc1-1
- 3.6.4~rc1-2
- 3.6.4-1
- 3.6.4-2
- 3.6.4-3build1
- 3.6.4-4
- 3.6.5~rc1-1
- 3.6.5-3
- 3.6.6-1~18.04
- 3.6.7-1~18.04
- 3.6.8-1~18.04.1
- Plages de versions concernées
- ECOSYSTEM: < 3.6.8-1~18.04.2
Mettez à jour vers 3.6.8-1~18.04.2
Sources originales
- http://www.securityfocus.com/bid/107400
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/L25RTMKCF62DLC2XVSNXGX7C7HXISLVM/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JSKPGPZQNTAULHW4UH63KGOOUIDE4RRB/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/D3LXPABKVLFYUHRYJPM3CSS5MS6FXKS7/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/AEZ5IQT7OF7Q2NCGIVABOWYGKO7YU3NJ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ICBEGRHIPHWPG2VGYS6R4EVKVUUF4AQW/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TR6GCO3WTV4D5L23WTCBF275VE6BVNI3/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/46PVWY5LFP4BRPG3BVQ5QEEFYBVEXHCK/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CFBAAGM27H73OLYBUA2IAZFSUN6KGLME/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IFAXBEY2TGOBDRKTR556JBXBVFSAKD6I/
- https://access.redhat.com/errata/RHSA-2019:0710
- https://access.redhat.com/errata/RHSA-2019:0765
- https://access.redhat.com/errata/RHSA-2019:0806
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00092.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00097.html
- https://access.redhat.com/errata/RHSA-2019:0902
- https://access.redhat.com/errata/RHSA-2019:0981
- https://access.redhat.com/errata/RHSA-2019:0997
- https://access.redhat.com/errata/RHBA-2019:0959
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00024.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JXASHCDD4PQFKTMKQN4YOP5ZH366ABN4/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JMWSKTNOHSUOT3L25QFJAVCFYZX46FYK/
- https://access.redhat.com/errata/RHSA-2019:1467
- https://nvd.nist.gov/vuln/detail/CVE-2019-9636