CVE-2020-11048
CVE-2020-11048 · Out-of-bounds Read in FreeRDPrdp_read_flow_control_pdu
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
In FreeRDP after 1.0 and before 2.0.0, there is an out-of-bounds read. It only allows to abort a session. No data extraction is possible. This has been fixed in 2.0.0.
CVSS 2.2 · Faible · EPSS 1,8% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
freerdp
- Versions du logiciel
- > 1.0, < 2.0.0: Concernée
Aucun correctif publié
freerdp2 Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 2.1.1+dfsg1-1
Mettez à jour vers 2.1.1+dfsg1-1
freerdp Ubuntu:16.04:LTS
- Versions du logiciel
- 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1
- 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.2
- 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.3
- Plages de versions concernées
- ECOSYSTEM: < 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.4
Mettez à jour vers 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.4
freerdp Ubuntu:18.04:LTS
- Versions du logiciel
- 1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1
- 1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1.18.04.1
- Plages de versions concernées
- ECOSYSTEM: < 1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1.18.04.2
Mettez à jour vers 1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1.18.04.2
freerdp2 Ubuntu:18.04:LTS
- Versions du logiciel
- 2.0.0~git20170725.1.1648deb+dfsg1-1
- 2.0.0~git20170725.1.1648deb+dfsg1-5
- 2.0.0~git20170725.1.1648deb+dfsg1-5ubuntu1
- 2.0.0~git20170725.1.1648deb+dfsg1-5ubuntu2
- 2.0.0~git20170725.1.1648deb+dfsg1-6
- 2.0.0~git20170725.1.1648deb+dfsg1-6build1
- 2.0.0~git20170725.1.1648deb+dfsg1-7
- 2.0.0~git20170725.1.1648deb+dfsg1-7ubuntu0.1
- Plages de versions concernées
- ECOSYSTEM: < 2.1.1+dfsg1-0ubuntu0.18.04.1
Mettez à jour vers 2.1.1+dfsg1-0ubuntu0.18.04.1
freerdp2 Ubuntu:20.04:LTS
- Versions du logiciel
- 2.0.0~git20190204.1.2693389a+dfsg1-1
- 2.0.0~git20190204.1.2693389a+dfsg1-2
- 2.0.0~git20190204.1.2693389a+dfsg1-2build1
- 2.0.0~git20190204.1.2693389a+dfsg1-2build2
- Plages de versions concernées
- ECOSYSTEM: < 2.1.1+dfsg1-0ubuntu0.20.04.1
Mettez à jour vers 2.1.1+dfsg1-0ubuntu0.20.04.1
Sources originales
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-hv8w-f2hx-5gcv
- https://github.com/FreeRDP/FreeRDP/issues/6007
- https://github.com/FreeRDP/FreeRDP/commit/9301bfe730c66180263248b74353daa99f5a969b
- https://usn.ubuntu.com/4379-1/
- https://usn.ubuntu.com/4382-1/
- https://lists.debian.org/debian-lts-announce/2020/08/msg00054.html
- https://lists.debian.org/debian-lts-announce/2023/10/msg00008.html
- https://nvd.nist.gov/vuln/detail/CVE-2020-11048