p PatchFirst

CVE-2020-15157

CVE-2020-15157 · containerd can be coerced into leaking credentials during image pull

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

In containerd (an industry-standard container runtime) before version 1.2.14 there is a credential leaking vulnerability. If a container image manifest in the OCI Image format or Docker Image V2 Schema 2 format includes a URL for the location of a specific image layer (otherwise known as a “foreign layer”), the default containerd resolver will follow that URL to attempt to download it. In v1.2.x but not 1.3.0 or later, the default containerd resolver will provide its authentication credentials if the server where the URL is located presents an HTTP 401 status code along with registry-specific HTTP headers. If an attacker publishes a public image with a manifest that directs one of the layers to be fetched from a web server they control and they trick a user or system into pulling the image, they can obtain the credentials used for pulling that image. In some cases, this may be the user's username and password for the registry. In other cases, this may be the credentials attached to the cloud virtual instance which can grant access to other cloud resources in the account. The default containerd resolver is used by the cri-containerd plugin (which can be used by Kubernetes), the ctr development tool, and other client programs that have explicitly linked against it. This vulnerability has been fixed in containerd 1.2.14. containerd 1.3 and later are not affected. If you are using containerd 1.3 or later, you are not affected. If you are using cri-containerd in the 1.2 series or prior, you should ensure you only pull images from trusted sources. Other container runtimes built on top of containerd but not using the default resolver (such as Docker) are not affected.

CVSS 6.1 · Moyenne · EPSS 2,3% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · containers

Produits et versions concernés

  • containerd

    Versions du logiciel
    • < 1.2.14: Concernée

    Aucun correctif publié

  • containerd Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 1.3.2~ds1-2

    Mettez à jour vers 1.3.2~ds1-2

  • containerd Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 1.3.2~ds1-2

    Mettez à jour vers 1.3.2~ds1-2

  • containerd Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 1.3.2~ds1-2

    Mettez à jour vers 1.3.2~ds1-2

  • docker.io Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 19.03.13+dfsg2-1

    Mettez à jour vers 19.03.13+dfsg2-1

  • docker.io Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 19.03.13+dfsg2-1

    Mettez à jour vers 19.03.13+dfsg2-1

  • docker.io Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 19.03.13+dfsg2-1

    Mettez à jour vers 19.03.13+dfsg2-1

  • containerd Ubuntu:16.04:LTS

    Versions du logiciel
    • 0.2.1-0ubuntu4~16.04
    • 0.2.3-0ubuntu1~16.04
    • 0.2.5-0ubuntu1~16.04.1
    • 1.2.6-0ubuntu1~16.04.2
    • 1.2.6-0ubuntu1~16.04.3
    Plages de versions concernées
    • ECOSYSTEM: < 1.2.6-0ubuntu1~16.04.4

    Mettez à jour vers 1.2.6-0ubuntu1~16.04.4

  • docker.io Ubuntu:16.04:LTS

    Versions du logiciel
    • 1.6.2~dfsg1-1ubuntu4
    • 1.10.2-0ubuntu3
    • 1.10.2-0ubuntu4
    • 1.10.3-0ubuntu1
    • 1.10.3-0ubuntu4
    • 1.10.3-0ubuntu5
    • 1.10.3-0ubuntu6
    • 1.11.2-0ubuntu5~16.04
    • 1.12.1-0ubuntu13~16.04.1
    • 1.12.3-0ubuntu4~16.04.2
    • 1.12.6-0ubuntu1~16.04.1
    • 1.13.1-0ubuntu1~16.04.2
    • 17.03.2-0ubuntu2~16.04.1
    • 18.06.1-0ubuntu1~16.04.2
    • 18.06.1-0ubuntu1.2~16.04.1
    • 18.09.2-0ubuntu1~16.04.1
    • 18.09.5-0ubuntu1~16.04.2
    • 18.09.7-0ubuntu1~16.04.1
    • 18.09.7-0ubuntu1~16.04.4
    • 18.09.7-0ubuntu1~16.04.5
    Plages de versions concernées
    • ECOSYSTEM: < 18.09.7-0ubuntu1~16.04.6

    Mettez à jour vers 18.09.7-0ubuntu1~16.04.6

  • docker.io Ubuntu:18.04:LTS

    Versions du logiciel
    • 1.13.1-0ubuntu6
    • 17.03.2-0ubuntu1
    • 17.03.2-0ubuntu3
    • 17.03.2-0ubuntu5
    • 17.12.1-0ubuntu1
    • 18.06.1-0ubuntu1~18.04.1
    • 18.06.1-0ubuntu1.2~18.04.1
    • 18.09.2-0ubuntu1~18.04.1
    • 18.09.5-0ubuntu1~18.04.2
    • 18.09.7-0ubuntu1~18.04.1
    • 18.09.7-0ubuntu1~18.04.3
    • 18.09.7-0ubuntu1~18.04.4
    • 19.03.6-0ubuntu1~18.04.1
    Plages de versions concernées
    • ECOSYSTEM: < 19.03.6-0ubuntu1~18.04.2

    Mettez à jour vers 19.03.6-0ubuntu1~18.04.2

  • docker.io Ubuntu:20.04:LTS

    Versions du logiciel
    • 19.03.2-0ubuntu1
    • 19.03.6-0ubuntu1
    • 19.03.8-0ubuntu1
    • 19.03.8-0ubuntu1.20.04
    Plages de versions concernées
    • ECOSYSTEM: < 19.03.8-0ubuntu1.20.04.1

    Mettez à jour vers 19.03.8-0ubuntu1.20.04.1

Sources originales

Vérifiez votre serveur →