CVE-2020-15278
CVE-2020-15278 · Unauthorized privilege escalation in Mod module
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Red Discord Bot before version 3.4.1 has an unauthorized privilege escalation exploit in the Mod module. This exploit allows Discord users with a high privilege level within the guild to bypass hierarchy checks when the application is in a specific condition that is beyond that user's control. By abusing this exploit, it is possible to perform destructive actions within the guild the user has high privileges in. This exploit has been fixed in version 3.4.1. As a workaround, unloading the Mod module with unload mod or, disabling the massban command with command disable global massban can render this exploit not accessible. We still highly recommend updating to 3.4.1 to completely patch this issue.
CVSS 7.7 · Élevée · EPSS 1,1% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: python
Produits et versions concernés
red-discordbot
- Versions du logiciel
- < 3.4.1: Concernée
Aucun correctif publié
red-discordbot PyPI
- Versions du logiciel
- 3.0.0
- 3.0.0b16
- 3.0.0b17
- 3.0.0b18
- 3.0.0b19
- 3.0.0b20
- 3.0.0b21
- 3.0.0rc1
- 3.0.0rc1.post1
- 3.0.0rc2
- 3.0.0rc3
- 3.0.0rc3.post1
- 3.0.1
- 3.0.2
- 3.1.0
- 3.1.1
- 3.1.2
- 3.1.3
- 3.1.4
- 3.1.5
- 3.1.6
- 3.1.7
- 3.1.8
- 3.1.9
- 3.2.0
- 3.2.1
- 3.2.2
- 3.2.3
- 3.3.0
- 3.3.1
- 3.3.10
- 3.3.11
- 3.3.12
- 3.3.2
- 3.3.3
- 3.3.4
- 3.3.5
- 3.3.6
- 3.3.7
- 3.3.8
- 3.3.9
- 3.4.0
- Plages de versions concernées
- ECOSYSTEM: < 3.4.1
Mettez à jour vers 3.4.1
red-discordbot PyPI
- Versions du logiciel
- 3.0.0
- 3.0.0b16
- 3.0.0b17
- 3.0.0b18
- 3.0.0b19
- 3.0.0b20
- 3.0.0b21
- 3.0.0rc1
- 3.0.0rc1.post1
- 3.0.0rc2
- 3.0.0rc3
- 3.0.0rc3.post1
- 3.0.1
- 3.0.2
- 3.1.0
- 3.1.1
- 3.1.2
- 3.1.3
- 3.1.4
- 3.1.5
- 3.1.6
- 3.1.7
- 3.1.8
- 3.1.9
- 3.2.0
- 3.2.1
- 3.2.2
- 3.2.3
- 3.3.0
- 3.3.1
- 3.3.10
- 3.3.11
- 3.3.12
- 3.3.2
- 3.3.3
- 3.3.4
- 3.3.5
- 3.3.6
- 3.3.7
- 3.3.8
- 3.3.9
- 3.4.0
- Plages de versions concernées
- GIT: < 726bfd38adfdfaef760412a68e01447b470f438b
- ECOSYSTEM: < 3.4.1
Mettez à jour vers 3.4.1