CVE-2020-1737
CVE-2020-1737
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
A flaw was found in Ansible 2.7.17 and prior, 2.8.9 and prior, and 2.9.6 and prior when using the Extract-Zip function from the win_unzip module as the extracted file(s) are not checked if they belong to the destination folder. An attacker could take advantage of this flaw by crafting an archive anywhere in the file system, using a path traversal. This issue is fixed in 2.10.
CVSS 7.5 · Élevée · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · python
Produits et versions concernés
ansible
- Versions du logiciel
- 2.7.17 and prior: Concernée
- 2.8.9 and prior: Concernée
- 2.9.6 and prior: Concernée
- fixed in 2.10: Concernée
Aucun correctif publié
ansible Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 2.9.7+dfsg-1
Mettez à jour vers 2.9.7+dfsg-1
ansible Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 2.9.7+dfsg-1
Mettez à jour vers 2.9.7+dfsg-1
ansible Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 2.9.7+dfsg-1
Mettez à jour vers 2.9.7+dfsg-1
ansible PyPI
- Versions du logiciel
- 2.8.0
- 2.8.0a1
- 2.8.0b1
- 2.8.0rc1
- 2.8.0rc2
- 2.8.0rc3
- 2.8.1
- 2.8.2
- 2.8.3
- 2.8.4
- 2.8.5
- 2.8.6
- 2.8.7
- 2.8.8
- Plages de versions concernées
- ECOSYSTEM: ≥ 2.8.0a1, < 2.8.9
Mettez à jour vers 2.8.9
ansible PyPI
- Versions du logiciel
- 2.9.0
- 2.9.0b1
- 2.9.0rc1
- 2.9.0rc2
- 2.9.0rc3
- 2.9.0rc4
- 2.9.0rc5
- 2.9.1
- 2.9.2
- 2.9.3
- 2.9.4
- 2.9.5
- Plages de versions concernées
- ECOSYSTEM: ≥ 2.9.0a1, < 2.9.6
Mettez à jour vers 2.9.6
ansible PyPI
- Versions du logiciel
- 1.0
- 1.1
- 1.2
- 1.2.1
- 1.2.2
- 1.2.3
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.4
- 1.4.1
- 1.4.2
- 1.4.3
- 1.4.4
- 1.4.5
- 1.5
- 1.5.1
- 1.5.2
- 1.5.3
- 1.5.4
- 1.5.5
- 1.6
- 1.6.1
- 1.6.10
- 1.6.2
- 1.6.3
- 1.6.4
- 1.6.5
- 1.6.6
- 1.6.7
- 1.6.8
- 1.6.9
- 1.7
- 1.7.1
- 1.7.2
- 1.8
- 1.8.1
- 1.8.2
- 1.8.3
- 1.8.4
- 1.9.0
- 1.9.0.1
- 1.9.1
- 1.9.2
- 1.9.3
- 1.9.4
- 1.9.5
- 1.9.6
- 2.0.0
- 2.0.0.0
- 2.0.0.1
- 2.0.0.2
- 2.0.1.0
- 2.0.2.0
- 2.1.0.0
- 2.1.1.0
- 2.1.2.0
- 2.1.3.0
- 2.1.4.0
- 2.1.5.0
- 2.1.6.0
- 2.2.0.0
- 2.2.1.0
- 2.2.2.0
- 2.2.3.0
- 2.3.0.0
- 2.3.1.0
- 2.3.2.0
- 2.3.3.0
- 2.4.0.0
- 2.4.1.0
- 2.4.2.0
- 2.4.3.0
- 2.4.4.0
- 2.4.5.0
- 2.4.6.0
- 2.5.0
- 2.5.0a1
- 2.5.0b1
- 2.5.0b2
- 2.5.0rc1
- 2.5.0rc2
- 2.5.0rc3
- 2.5.1
- 2.5.10
- 2.5.11
- 2.5.12
- 2.5.13
- 2.5.14
- 2.5.15
- 2.5.2
- 2.5.3
- 2.5.4
- 2.5.5
- 2.5.6
- 2.5.7
- 2.5.8
- 2.5.9
- 2.6.0
- 2.6.0a1
- 2.6.0a2
- 2.6.0rc1
- 2.6.0rc2
- 2.6.0rc3
- 2.6.0rc4
- 2.6.0rc5
- 2.6.1
- 2.6.10
- 2.6.11
- 2.6.12
- 2.6.13
- 2.6.14
- 2.6.15
- 2.6.16
- 2.6.17
- 2.6.18
- 2.6.19
- 2.6.2
- 2.6.20
- 2.6.3
- 2.6.4
- 2.6.5
- 2.6.6
- 2.6.7
- 2.6.8
- 2.6.9
- 2.7.0
- 2.7.0.dev0
- 2.7.0a1
- 2.7.0b1
- 2.7.0rc1
- 2.7.0rc2
- 2.7.0rc3
- 2.7.0rc4
- 2.7.1
- 2.7.10
- 2.7.11
- 2.7.12
- 2.7.13
- 2.7.14
- 2.7.15
- 2.7.16
- 2.7.2
- 2.7.3
- 2.7.4
- 2.7.5
- 2.7.6
- 2.7.7
- 2.7.8
- 2.7.9
- Plages de versions concernées
- ECOSYSTEM: < 2.7.17
Mettez à jour vers 2.7.17
ansible PyPI
- Versions du logiciel
- 1.0
- 1.1
- 1.2
- 1.2.1
- 1.2.2
- 1.2.3
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.4
- 1.4.1
- 1.4.2
- 1.4.3
- 1.4.4
- 1.4.5
- 1.5
- 1.5.1
- 1.5.2
- 1.5.3
- 1.5.4
- 1.5.5
- 1.6
- 1.6.1
- 1.6.2
- 1.6.3
- 1.6.4
- 1.6.5
- 1.6.6
- 1.6.7
- 1.6.8
- 1.6.9
- 1.6.10
- 1.7
- 1.7.1
- 1.7.2
- 1.8
- 1.8.1
- 1.8.2
- 1.8.3
- 1.8.4
- 1.9.0
- 1.9.0.1
- 1.9.1
- 1.9.2
- 1.9.3
- 1.9.4
- 1.9.5
- 1.9.6
- 2.0.0.0
- 2.0.0
- 2.0.0.1
- 2.0.0.2
- 2.0.1.0
- 2.0.2.0
- 2.1.0.0
- 2.1.1.0
- 2.1.2.0
- 2.1.3.0
- 2.1.4.0
- 2.1.5.0
- 2.1.6.0
- 2.2.0.0
- 2.2.1.0
- 2.2.2.0
- 2.2.3.0
- 2.3.0.0
- 2.3.1.0
- 2.3.2.0
- 2.3.3.0
- 2.4.0.0
- 2.4.1.0
- 2.4.2.0
- 2.4.3.0
- 2.4.4.0
- 2.4.5.0
- 2.4.6.0
- 2.5.0a1
- 2.5.0b1
- 2.5.0b2
- 2.5.0rc1
- 2.5.0rc2
- 2.5.0rc3
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.5.4
- 2.5.5
- 2.5.6
- 2.5.7
- 2.5.8
- 2.5.9
- 2.5.10
- 2.5.11
- 2.5.12
- 2.5.13
- 2.5.14
- 2.5.15
- 2.6.0a1
- 2.6.0a2
- 2.6.0rc1
- 2.6.0rc2
- 2.6.0rc3
- 2.6.0rc4
- 2.6.0rc5
- 2.6.0
- 2.6.1
- 2.6.2
- 2.6.3
- 2.6.4
- 2.6.5
- 2.6.6
- 2.6.7
- 2.6.8
- 2.6.9
- 2.6.10
- 2.6.11
- 2.6.12
- 2.6.13
- 2.6.14
- 2.6.15
- 2.6.16
- 2.6.17
- 2.6.18
- 2.6.19
- 2.6.20
- 2.7.0.dev0
- 2.7.0a1
- 2.7.0b1
- 2.7.0rc1
- 2.7.0rc2
- 2.7.0rc3
- 2.7.0rc4
- 2.7.0
- 2.7.1
- 2.7.2
- 2.7.3
- 2.7.4
- 2.7.5
- 2.7.6
- 2.7.7
- 2.7.8
- 2.7.9
- 2.7.10
- 2.7.11
- 2.7.12
- 2.7.13
- 2.7.14
- 2.7.15
- 2.7.16
- 2.8.0
- 2.8.1
- 2.8.2
- 2.8.3
- 2.8.4
- 2.8.5
- 2.8.6
- 2.8.7
- 2.8.8
- 2.9.0
- 2.9.1
- 2.9.2
- 2.9.3
- 2.9.4
- 2.9.5
- Plages de versions concernées
- ECOSYSTEM: < 2.7.17 ∪ ≥ 2.8.0, < 2.8.9 ∪ ≥ 2.9.0, < 2.9.6
Mettez à jour vers 2.7.17; Mettez à jour vers 2.8.9; Mettez à jour vers 2.9.6
ansible Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 1.1+dfsg-1
- 1.3.4+dfsg-1
- 1.4.0+dfsg-1
- 1.4.1+dfsg-1
- 1.4.3+dfsg-1
- 1.4.4+dfsg-1
- 1.5.4+dfsg-1
- 1.5.4+dfsg-1ubuntu0.1~esm1
- 1.5.4+dfsg-1ubuntu0.1~esm2
- 1.5.4+dfsg-1ubuntu0.1~esm3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
ansible Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 1.9.2+dfsg-2
- 1.9.4-1
- 2.0.0.2-2
- 2.0.0.2-2ubuntu1
- 2.0.0.2-2ubuntu1.1
- 2.0.0.2-2ubuntu1.2
- 2.0.0.2-2ubuntu1.3
- 2.0.0.2-2ubuntu1.3+esm1
- 2.0.0.2-2ubuntu1.3+esm2
- 2.0.0.2-2ubuntu1.3+esm3
- 2.0.0.2-2ubuntu1.3+esm4
- 2.0.0.2-2ubuntu1.3+esm5
- 2.0.0.2-2ubuntu1.3+esm6
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
ansible Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 2.3.1.0+dfsg-2
- 2.5.0+dfsg-1
- 2.5.1+dfsg-1
- 2.5.1+dfsg-1ubuntu0.1
- 2.5.1+dfsg-1ubuntu0.1+esm1
- 2.5.1+dfsg-1ubuntu0.1+esm2
- 2.5.1+dfsg-1ubuntu0.1+esm3
- 2.5.1+dfsg-1ubuntu0.1+esm4
- 2.5.1+dfsg-1ubuntu0.1+esm5
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
ansible Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 2.8.3+dfsg-1
- 2.8.6+dfsg-1
- 2.9.2+dfsg-1
- 2.9.4+dfsg-1
- 2.9.6+dfsg-1
- 2.9.6+dfsg-1ubuntu0.1~esm1
- 2.9.6+dfsg-1ubuntu0.1~esm2
- 2.9.6+dfsg-1ubuntu0.1~esm3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1737
- https://github.com/ansible/ansible/issues/67795
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FWDK3QUVBULS3Q3PQTGEKUQYPSNOU5M3/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QT27K5ZRGDPCH7GT3DRI3LO4IVDVQUB7/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/U3IMV3XEIUXL6S4KPLYYM4TVJQ2VNEP2/
- https://security.gentoo.org/glsa/202006-11
- https://nvd.nist.gov/vuln/detail/CVE-2020-1737