CVE-2020-25631
CVE-2020-25631
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
A vulnerability was found in Moodle 3.9 to 3.9.1, 3.8 to 3.8.4 and 3.7 to 3.7.7 where it was possible to include JavaScript in a book's chapter title, which was not escaped on the "Add new chapter" page. This is fixed in 3.9.2, 3.8.5 and 3.7.8.
CVSS 6.1 · Moyenne · EPSS 0,9% · Correctif disponible
- Publication
- Mise à jour
Produits et versions concernés
moodle
- Versions du logiciel
- 3.9 to 3.9.1, 3.8 to 3.8.4 and 3.7 to 3.7.7: Concernée
Aucun correctif publié
moodle/moodle Packagist
- Versions du logiciel
- v3.9.0
- v3.9.0-beta
- v3.9.0-rc1
- v3.9.0-rc2
- v3.9.0-rc3
- v3.9.1
- Plages de versions concernées
- ECOSYSTEM: ≥ 3.9, < 3.9.2
Mettez à jour vers 3.9.2
moodle/moodle Packagist
- Versions du logiciel
- v3.8.0
- v3.8.0-beta
- v3.8.0-rc1
- v3.8.1
- v3.8.2
- v3.8.3
- v3.8.4
- Plages de versions concernées
- ECOSYSTEM: ≥ 3.8, < 3.8.5
Mettez à jour vers 3.8.5
moodle/moodle Packagist
- Versions du logiciel
- v3.7.0
- v3.7.0-beta
- v3.7.0-rc1
- v3.7.0-rc2
- v3.7.1
- v3.7.2
- v3.7.3
- v3.7.4
- v3.7.5
- v3.7.6
- v3.7.7
- Plages de versions concernées
- ECOSYSTEM: ≥ 3.7, < 3.7.8
Mettez à jour vers 3.7.8
moodle Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 2.7.9+dfsg-1
- 2.7.10+dfsg-1
- 2.7.11+dfsg-1
- 2.7.11+dfsg-2
- 2.7.12+dfsg-1
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
moodle Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié