p PatchFirst

CVE-2020-25698

CVE-2020-25698

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Users' enrollment capabilities were not being sufficiently checked in Moodle when they are restored into an existing course. This could lead to them unenrolling users without having permission to do so. Versions affected: 3.5 to 3.5.14, 3.7 to 3.7.8, 3.8 to 3.8.5, 3.9 to 3.9.2 and earlier unsupported versions. Fixed in 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

CVSS 7.5 · Élevée · EPSS 1,9% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · php

Produits et versions concernés

  • moodle

    Versions du logiciel
    • Fixed in 3.9.3: Concernée
    • Fixed in 3.8.6: Concernée
    • Fixed in 3.7.9: Concernée
    • Fixed in 3.5.15: Concernée
    • Fixed in 3.10: Concernée

    Aucun correctif publié

  • moodle/moodle Packagist

    Versions du logiciel
    • v3.9.0
    • v3.9.1
    • v3.9.2
    Plages de versions concernées
    • ECOSYSTEM: ≥ 3.9.0, < 3.9.3

    Mettez à jour vers 3.9.3

  • moodle/moodle Packagist

    Versions du logiciel
    • v3.8.0
    • v3.8.1
    • v3.8.2
    • v3.8.3
    • v3.8.4
    • v3.8.5
    Plages de versions concernées
    • ECOSYSTEM: ≥ 3.8.0, < 3.8.6

    Mettez à jour vers 3.8.6

  • moodle/moodle Packagist

    Versions du logiciel
    • v3.7.0
    • v3.7.1
    • v3.7.2
    • v3.7.3
    • v3.7.4
    • v3.7.5
    • v3.7.6
    • v3.7.7
    • v3.7.8
    Plages de versions concernées
    • ECOSYSTEM: ≥ 3.7.0, < 3.7.9

    Mettez à jour vers 3.7.9

  • moodle/moodle Packagist

    Versions du logiciel
    • v3.5.0
    • v3.5.0-beta
    • v3.5.0-rc1
    • v3.5.1
    • v3.5.10
    • v3.5.11
    • v3.5.12
    • v3.5.13
    • v3.5.14
    • v3.5.2
    • v3.5.3
    • v3.5.4
    • v3.5.5
    • v3.5.6
    • v3.5.7
    • v3.5.8
    • v3.5.9
    Plages de versions concernées
    • ECOSYSTEM: ≥ 3.5, < 3.5.15

    Mettez à jour vers 3.5.15

  • moodle Ubuntu:Pro:16.04:LTS

    Versions du logiciel
    • 2.7.9+dfsg-1
    • 2.7.10+dfsg-1
    • 2.7.11+dfsg-1
    • 2.7.11+dfsg-2
    • 2.7.12+dfsg-1
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • moodle Ubuntu:Pro:18.04:LTS

    Versions du logiciel
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →