CVE-2020-25701
CVE-2020-25701
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
If the upload course tool in Moodle was used to delete an enrollment method which did not exist or was not already enabled, the tool would erroneously enable that enrollment method. This could lead to unintended users gaining access to the course. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.
CVSS 5.3 · Moyenne · EPSS 1,4% · Correctif disponible
- Publication
- Mise à jour
Produits et versions concernés
moodle
- Versions du logiciel
- Fixed in 3.9.3: Concernée
- Fixed in 3.8.6: Concernée
- Fixed in 3.7.9: Concernée
- Fixed in 3.5.15: Concernée
- Fixed in 3.10: Concernée
Aucun correctif publié
moodle/moodle Packagist
- Versions du logiciel
- v3.9.0
- v3.9.1
- v3.9.2
- Plages de versions concernées
- ECOSYSTEM: ≥ 3.9.0, < 3.9.3
Mettez à jour vers 3.9.3
moodle/moodle Packagist
- Versions du logiciel
- v3.8.0
- v3.8.1
- v3.8.2
- v3.8.3
- v3.8.4
- v3.8.5
- Plages de versions concernées
- ECOSYSTEM: ≥ 3.8.0, < 3.8.6
Mettez à jour vers 3.8.6
moodle/moodle Packagist
- Versions du logiciel
- v3.7.0
- v3.7.1
- v3.7.2
- v3.7.3
- v3.7.4
- v3.7.5
- v3.7.6
- v3.7.7
- v3.7.8
- Plages de versions concernées
- ECOSYSTEM: ≥ 3.7.0, < 3.7.9
Mettez à jour vers 3.7.9
moodle/moodle Packagist
- Versions du logiciel
- v3.5.0
- v3.5.0-beta
- v3.5.0-rc1
- v3.5.1
- v3.5.10
- v3.5.11
- v3.5.12
- v3.5.13
- v3.5.14
- v3.5.2
- v3.5.3
- v3.5.4
- v3.5.5
- v3.5.6
- v3.5.7
- v3.5.8
- v3.5.9
- Plages de versions concernées
- ECOSYSTEM: ≥ 3.5, < 3.5.15
Mettez à jour vers 3.5.15
moodle Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 2.7.9+dfsg-1
- 2.7.10+dfsg-1
- 2.7.11+dfsg-1
- 2.7.11+dfsg-2
- 2.7.12+dfsg-1
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
moodle Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://bugzilla.redhat.com/show_bug.cgi?id=1895432
- https://moodle.org/mod/forum/discuss.php?d=413939
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/B55KXBVAT45MDASJ3EK6VIGQOYGJ4NH6/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4NNFCHPPHRJNJROIX6SYMHOC6HMKP3GU/
- https://nvd.nist.gov/vuln/detail/CVE-2020-25701