p PatchFirst

CVE-2020-26250

CVE-2020-26250 · Base class whitelist configuration ignored in OAuthenticator

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

OAuthenticator is an OAuth login mechanism for JupyterHub. In oauthenticator from version 0.12.0 and before 0.12.2, the deprecated (in jupyterhub 1.2) configuration `Authenticator.whitelist`, which should be transparently mapped to `Authenticator.allowed_users` with a warning, is instead ignored by OAuthenticator classes, resulting in the same behavior as if this configuration has not been set. If this is the only mechanism of authorization restriction (i.e. no group or team restrictions in configuration) then all authenticated users will be allowed. Provider-based restrictions, including deprecated values such as `GitHubOAuthenticator.org_whitelist` are **not** affected. All users of OAuthenticator 0.12.0 and 0.12.1 with JupyterHub 1.2 (JupyterHub Helm chart 0.10.0-0.10.5) who use the `admin.whitelist.users` configuration in the jupyterhub helm chart or the `c.Authenticator.whitelist` configuration directly. Users of other deprecated configuration, e.g. `c.GitHubOAuthenticator.team_whitelist` are **not** affected. If you see a log line like this and expect a specific list of allowed usernames: "[I 2020-11-27 16:51:54.528 JupyterHub app:1717] Not using allowed_users. Any authenticated user will be allowed." you are likely affected. Updating oauthenticator to 0.12.2 is recommended. A workaround is to replace the deprecated `c.Authenticator.whitelist = ...` with `c.Authenticator.allowed_users = ...`. If any users have been authorized during this time who should not have been, they must be deleted via the API or admin interface, per the referenced documentation.

CVSS 6.3 · Moyenne · EPSS 1,1% · Correctif disponible

Publication
Mise à jour

Pile logicielle: python

Produits et versions concernés

  • oauthenticator

    Versions du logiciel
    • >= 0.12.0, < 0.12.2: Concernée

    Aucun correctif publié

  • oauthenticator PyPI

    Versions du logiciel
    • 0.12.0
    • 0.12.1
    Plages de versions concernées
    • ECOSYSTEM: ≥ 0.12.0, < 0.12.2

    Mettez à jour vers 0.12.2

  • oauthenticator PyPI

    Versions du logiciel
    • 0.12.0
    • 0.12.1
    Plages de versions concernées
    • GIT: < a4aac191c16cf6281f3d346615aefa75702b02d7
    • ECOSYSTEM: ≥ 0.12.0, < 0.12.2

    Mettez à jour vers 0.12.2

Sources originales

Vérifiez votre serveur →