p PatchFirst

CVE-2020-4049

CVE-2020-4049 · Authenticated self-XSS via theme uploads in WordPress

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

In affected versions of WordPress, when uploading themes, the name of the theme folder can be crafted in a way that could lead to JavaScript execution in /wp-admin on the themes page. This does require an admin to upload the theme, and is low severity self-XSS. This has been patched in version 5.4.2, along with all the previously affected versions via a minor release (5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34).

CVSS 2.4 · Faible · EPSS 2,5% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • wordpress-develop

    Versions du logiciel
    • >= 5.4.0, < 5.4.2: Concernée
    • >= 5.3.0, < 5.3.4: Concernée
    • >= 5.2.0, < 5.2.7: Concernée
    • >= 5.1.0, < 5.1.6: Concernée
    • >= 5.0.0, < 5.0.10: Concernée
    • >= 4.9.0, < 4.9.15: Concernée
    • >= 4.8.0, < 4.8.14: Concernée
    • >= 4.7.0, < 4.7.18: Concernée
    • >= 4.6.0, < 4.6.19: Concernée
    • >= 4.5.0, < 4.5.22: Concernée
    • >= 4.4.0, < 4.4.23: Concernée
    • >= 4.3.0, < 4.3.24: Concernée
    • >= 4.2.0, < 4.2.28: Concernée
    • >= 4.1.0, < 4.1.31: Concernée
    • >= 4.0.0, < 4.0.31: Concernée
    • >= 3.9.0, < 3.9.32: Concernée
    • >= 3.8.0, < 3.8.34: Concernée
    • >= 3.7.0, < 3.7.34: Concernée

    Aucun correctif publié

  • wordpress Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 5.4.2+dfsg1-1

    Mettez à jour vers 5.4.2+dfsg1-1

  • wordpress Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 5.4.2+dfsg1-1

    Mettez à jour vers 5.4.2+dfsg1-1

  • wordpress Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 5.4.2+dfsg1-1

    Mettez à jour vers 5.4.2+dfsg1-1

  • wordpress Ubuntu:16.04:LTS

    Versions du logiciel
    • 4.3+dfsg-1
    • 4.3.1+dfsg-1
    • 4.4+dfsg-1
    • 4.4.1+dfsg-1
    • 4.4.2+dfsg-1
    • 4.4.2+dfsg-1ubuntu1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • wordpress Ubuntu:18.04:LTS

    Versions du logiciel
    • 4.8.2+dfsg-2
    • 4.8.3+dfsg-1
    • 4.9.1+dfsg-1
    • 4.9.2+dfsg-1
    • 4.9.4+dfsg-1
    • 4.9.5+dfsg1-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • wordpress Ubuntu:20.04:LTS

    Versions du logiciel
    • 5.2.2+dfsg1-1
    • 5.2.4+dfsg1-1
    • 5.3.2+dfsg1-1
    • 5.3.2+dfsg1-1ubuntu1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • wordpress Ubuntu:22.04:LTS

    Versions du logiciel
    • 5.7.1+dfsg1-2ubuntu1
    • 5.8.1+dfsg1-2ubuntu1
    • 5.8.2+dfsg1-1ubuntu1
    • 5.8.3+dfsg1-1ubuntu1
    • 5.8.3+dfsg1-1ubuntu1.1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →