p PatchFirst

CVE-2021-21299

CVE-2021-21299 · Multiple Transfer-Encoding headers misinterprets request payload

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

hyper is an open-source HTTP library for Rust (crates.io). In hyper from version 0.12.0 and before versions 0.13.10 and 0.14.3 there is a vulnerability that can enable a request smuggling attack. The HTTP server code had a flaw that incorrectly understands some requests with multiple transfer-encoding headers to have a chunked payload, when it should have been rejected as illegal. This combined with an upstream HTTP proxy that understands the request payload boundary differently can result in "request smuggling" or "desync attacks". To determine if vulnerable, all these things must be true: 1) Using hyper as an HTTP server (the client is not affected), 2) Using HTTP/1.1 (HTTP/2 does not use transfer-encoding), 3) Using a vulnerable HTTP proxy upstream to hyper. If an upstream proxy correctly rejects the illegal transfer-encoding headers, the desync attack cannot succeed. If there is no proxy upstream of hyper, hyper cannot start the desync attack, as the client will repair the headers before forwarding. This is fixed in versions 0.14.3 and 0.13.10. As a workaround one can take the following options: 1) Reject requests that contain a `transfer-encoding` header, 2) Ensure any upstream proxy handles `transfer-encoding` correctly.

CVSS 4.8 · Moyenne · EPSS 4,7% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • hyper

    Versions du logiciel
    • < 0.13.10: Concernée
    • >= 0.14.0, < 0.14.3: Concernée

    Aucun correctif publié

  • rust-hyper Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 0.14.19-1

    Mettez à jour vers 0.14.19-1

  • rust-hyper Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 0.14.19-1

    Mettez à jour vers 0.14.19-1

  • rust-hyper Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 0.14.19-1

    Mettez à jour vers 0.14.19-1

  • rust-hyper Ubuntu:20.04:LTS

    Versions du logiciel
    • 0.12.35-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • rust-hyper Ubuntu:24.04:LTS

    Versions du logiciel
    • 0.14.25-1
    • 0.14.27-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • rust-hyper Ubuntu:25.10

    Versions du logiciel
    • 1.5.2-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • rust-hyper Ubuntu:26.10

    Versions du logiciel
    • 1.8.1-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • rust-hyper Ubuntu:26.04:LTS

    Versions du logiciel
    • 1.5.2-1
    • 1.7.0-1
    • 1.8.1-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →