CVE-2021-29447
CVE-2021-29447 · WordPress Authenticated XXE attack when installation is running PHP 8
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Wordpress is an open source CMS. A user with the ability to upload files (like an Author) can exploit an XML parsing issue in the Media Library leading to XXE attacks. This requires WordPress installation to be using PHP 8. Access to internal files is possible in a successful XXE attack. This has been patched in WordPress version 5.7.1, along with the older affected versions via a minor release. We strongly recommend you keep auto-updates enabled.
CVSS 7.1 · Élevée · EPSS 85,7% · Code d’exploitation public · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
wordpress-develop
- Versions du logiciel
- >= 5.6.0, < 5.7.1: Concernée
Aucun correctif publié
wordpress Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 5.7.1+dfsg1-1
Mettez à jour vers 5.7.1+dfsg1-1
wordpress Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 5.7.1+dfsg1-1
Mettez à jour vers 5.7.1+dfsg1-1
wordpress Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 5.7.1+dfsg1-1
Mettez à jour vers 5.7.1+dfsg1-1
wordpress Ubuntu:16.04:LTS
- Versions du logiciel
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
wordpress Ubuntu:18.04:LTS
- Versions du logiciel
- 4.8.2+dfsg-2
- 4.8.3+dfsg-1
- 4.9.1+dfsg-1
- 4.9.2+dfsg-1
- 4.9.4+dfsg-1
- 4.9.5+dfsg1-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
wordpress Ubuntu:20.04:LTS
- Versions du logiciel
- 5.2.2+dfsg1-1
- 5.2.4+dfsg1-1
- 5.3.2+dfsg1-1
- 5.3.2+dfsg1-1ubuntu1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
wordpress Ubuntu:22.04:LTS
- Versions du logiciel
- 5.7.1+dfsg1-2ubuntu1
- 5.8.1+dfsg1-2ubuntu1
- 5.8.2+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1.1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
wordpress Ubuntu:24.04:LTS
- Versions du logiciel
- 6.2+dfsg1-1ubuntu1
- 6.4.3+dfsg1-1ubuntu1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
wordpress Ubuntu:25.10
- Versions du logiciel
- 6.7.2+dfsg1-1.1ubuntu1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
wordpress Ubuntu:26.10
- Versions du logiciel
- 6.7.2+dfsg1-1.1ubuntu2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
wordpress Ubuntu:26.04:LTS
- Versions du logiciel
- 6.7.2+dfsg1-1.1ubuntu1
- 6.7.2+dfsg1-1.1ubuntu2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-rv47-pc52-qrhh
- https://wordpress.org/news/category/security/
- https://lists.debian.org/debian-lts-announce/2021/04/msg00017.html
- https://www.debian.org/security/2021/dsa-4896
- http://packetstormsecurity.com/files/163148/XML-External-Entity-Via-MP3-File-Upload-On-WordPress.html
- http://packetstormsecurity.com/files/164198/WordPress-5.7-Media-Library-XML-Injection.html
- https://blog.sonarsource.com/wordpress-xxe-security-vulnerability/
- https://nvd.nist.gov/vuln/detail/CVE-2021-29447