CVE-2021-32617
CVE-2021-32617 · Denial of service in Exiv2
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. An inefficient algorithm (quadratic complexity) was found in Exiv2 versions v0.27.3 and earlier. The inefficient algorithm is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service, if they can trick the victim into running Exiv2 on a crafted image file. The bug is fixed in version v0.27.4. Note that this bug is only triggered when _writing_ the metadata, which is a less frequently used Exiv2 operation than _reading_ the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as `rm`.
CVSS 4.7 · Moyenne · EPSS 1,2% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
exiv2
- Versions du logiciel
- <= 0.27.3: Concernée
Aucun correctif publié
exiv2 Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 0.27.5-1
Mettez à jour vers 0.27.5-1
exiv2 Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 0.27.5-1
Mettez à jour vers 0.27.5-1
exiv2 Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 0.27.5-1
Mettez à jour vers 0.27.5-1
exiv2 Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 0.25-1ubuntu1
- 0.25-2.1
- 0.25-2.1ubuntu16.04.1
- 0.25-2.1ubuntu16.04.2
- 0.25-2.1ubuntu16.04.3
- 0.25-2.1ubuntu16.04.4
- 0.25-2.1ubuntu16.04.5
- 0.25-2.1ubuntu16.04.6
- 0.25-2.1ubuntu16.04.7+esm1
- Plages de versions concernées
- ECOSYSTEM: < 0.25-2.1ubuntu16.04.7+esm2
Mettez à jour vers 0.25-2.1ubuntu16.04.7+esm2
exiv2 Ubuntu:18.04:LTS
- Versions du logiciel
- 0.25-3.1
- 0.25-3.1ubuntu0.18.04.1
- 0.25-3.1ubuntu0.18.04.2
- 0.25-3.1ubuntu0.18.04.3
- 0.25-3.1ubuntu0.18.04.4
- 0.25-3.1ubuntu0.18.04.5
- 0.25-3.1ubuntu0.18.04.7
- Plages de versions concernées
- ECOSYSTEM: < 0.25-3.1ubuntu0.18.04.9
Mettez à jour vers 0.25-3.1ubuntu0.18.04.9
exiv2 Ubuntu:20.04:LTS
- Versions du logiciel
- 0.25-4ubuntu2
- 0.25-4ubuntu3
- 0.27.2-8ubuntu2
- 0.27.2-8ubuntu2.2
- Plages de versions concernées
- ECOSYSTEM: < 0.27.2-8ubuntu2.4
Mettez à jour vers 0.27.2-8ubuntu2.4
Sources originales
- https://github.com/Exiv2/exiv2/security/advisories/GHSA-w8mv-g8qq-36mj
- https://github.com/Exiv2/exiv2/pull/1657
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/5I3RRZUGSBIUYZ5TIHLN55PKMAWCSJ5G/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/M2BPQNJKTRIDINTVJ22QMMTIZEPHVKXK/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/RQAKFIQHW2AS3AGSJM42ABOA6CWIJBGM/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TZ5SGWHK64TB7ADRSVBGHEPDFN5CSOO3/
- https://security.gentoo.org/glsa/202312-06
- https://nvd.nist.gov/vuln/detail/CVE-2021-32617