p PatchFirst

CVE-2021-32671

CVE-2021-32671 · XSS vulnerability with translator

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Flarum is a forum software for building communities. Flarum's translation system allowed for string inputs to be converted into HTML DOM nodes when rendered. This change was made after v0.1.0-beta.16 (our last beta before v1.0.0) and was not noticed or documented. This allowed for any user to type malicious HTML markup within certain user input fields and have this execute on client browsers. The example which led to the discovery of this vulnerability was in the forum search box. Entering faux-malicious HTML markup, such as <script>alert('test')</script> resulted in an alert box appearing on the forum. This attack could also be modified to perform AJAX requests on behalf of a user, possibly deleting discussions, modifying their settings or profile, or even modifying settings on the Admin panel if the attack was targetted towards a privileged user. All Flarum communities that run flarum v1.0.0 or v1.0.1 are impacted. The vulnerability has been fixed and published as flarum/core v1.0.2. All communities running Flarum v1.0 have to upgrade as soon as possible to v1.0.2.

CVSS 10.0 · Critique · EPSS 40,0% · Correctif disponible

Publication
Mise à jour

Pile logicielle: php

Produits et versions concernés

  • core

    Versions du logiciel
    • >= 1.0.0, < 1.0.2: Concernée

    Aucun correctif publié

  • flarum/core Packagist

    Versions du logiciel
    • v1.0.0
    • v1.0.1
    Plages de versions concernées
    • ECOSYSTEM: ≥ 1.0.0, < 1.0.2

    Mettez à jour vers 1.0.2

Sources originales

Vérifiez votre serveur →