CVE-2021-3711
CVE-2021-3711 · SM2 Decryption Buffer Overflow
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
In order to decrypt SM2 encrypted data an application is expected to call the API function EVP_PKEY_decrypt(). Typically an application will call this function twice. The first time, on entry, the "out" parameter can be NULL and, on exit, the "outlen" parameter is populated with the buffer size required to hold the decrypted plaintext. The application can then allocate a sufficiently sized buffer and call EVP_PKEY_decrypt() again, but this time passing a non-NULL value for the "out" parameter. A bug in the implementation of the SM2 decryption code means that the calculation of the buffer size required to hold the plaintext returned by the first call to EVP_PKEY_decrypt() can be smaller than the actual size required by the second call. This can lead to a buffer overflow when EVP_PKEY_decrypt() is called by the application a second time with a buffer that is too small. A malicious attacker who is able present SM2 content for decryption to an application could cause attacker chosen data to overflow the buffer by up to a maximum of 62 bytes altering the contents of other data held after the buffer, possibly changing application behaviour or causing the application to crash. The location of the buffer is application dependent but is typically heap allocated. Fixed in OpenSSL 1.1.1l (Affected 1.1.1-1.1.1k).
CVSS 9.8 · Critique · EPSS 87,8% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · network
Produits et versions concernés
openssl
- Versions du logiciel
- Fixed in OpenSSL 1.1.1l (Affected 1.1.1-1.1.1k): Concernée
Aucun correctif publié
openssl Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 1.1.1l-1
Mettez à jour vers 1.1.1l-1
openssl Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 1.1.1l-1
Mettez à jour vers 1.1.1l-1
openssl Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 1.1.1l-1
Mettez à jour vers 1.1.1l-1
openssl Ubuntu:18.04:LTS
- Versions du logiciel
- 1.0.2g-1ubuntu13
- 1.0.2g-1ubuntu14
- 1.0.2n-1ubuntu1
- 1.1.0g-2ubuntu1
- 1.1.0g-2ubuntu2
- 1.1.0g-2ubuntu3
- 1.1.0g-2ubuntu4
- 1.1.0g-2ubuntu4.1
- 1.1.0g-2ubuntu4.3
- 1.1.1-1ubuntu2.1~18.04.1
- 1.1.1-1ubuntu2.1~18.04.2
- 1.1.1-1ubuntu2.1~18.04.3
- 1.1.1-1ubuntu2.1~18.04.4
- 1.1.1-1ubuntu2.1~18.04.5
- 1.1.1-1ubuntu2.1~18.04.6
- 1.1.1-1ubuntu2.1~18.04.7
- 1.1.1-1ubuntu2.1~18.04.8
- 1.1.1-1ubuntu2.1~18.04.9
- 1.1.1-1ubuntu2.1~18.04.10
- Plages de versions concernées
- ECOSYSTEM: < 1.1.1-1ubuntu2.1~18.04.13
Mettez à jour vers 1.1.1-1ubuntu2.1~18.04.13
openssl Ubuntu:Pro:FIPS-updates:18.04:LTS
- Versions du logiciel
- 1.1.1-1ubuntu2.fips.2.1~18.04.5.1
- 1.1.1-1ubuntu2.fips.2.1~18.04.6.1
- 1.1.1-1ubuntu2.fips.2.1~18.04.7.1
- 1.1.1-1ubuntu2.fips.2.1~18.04.9.1
- 1.1.1-1ubuntu2.fips.2.1~18.04.9.2
- 1.1.1-1ubuntu2.fips.2.1~18.04.9.3
- Plages de versions concernées
- ECOSYSTEM: < 1.1.1-1ubuntu2.fips.2.1~18.04.13.2
Mettez à jour vers 1.1.1-1ubuntu2.fips.2.1~18.04.13.2
openssl Ubuntu:Pro:FIPS:18.04:LTS
- Versions du logiciel
- 1.1.1-1ubuntu2.fips.2.1~18.04.3.1
- 1.1.1-1ubuntu2.fips.2.1~18.04.15.2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
openssl Ubuntu:20.04:LTS
- Versions du logiciel
- 1.1.1c-1ubuntu4
- 1.1.1d-2ubuntu3
- 1.1.1d-2ubuntu6
- 1.1.1f-1ubuntu1
- 1.1.1f-1ubuntu2
- 1.1.1f-1ubuntu2.1
- 1.1.1f-1ubuntu2.2
- 1.1.1f-1ubuntu2.3
- 1.1.1f-1ubuntu2.4
- 1.1.1f-1ubuntu2.5
- Plages de versions concernées
- ECOSYSTEM: < 1.1.1f-1ubuntu2.8
Mettez à jour vers 1.1.1f-1ubuntu2.8
openssl Ubuntu:Pro:FIPS-updates:20.04:LTS
- Versions du logiciel
- 1.1.1f-1ubuntu2.fips.7
- Plages de versions concernées
- ECOSYSTEM: < 1.1.1f-1ubuntu2.fips.7.2
Mettez à jour vers 1.1.1f-1ubuntu2.fips.7.2
openssl Ubuntu:Pro:FIPS:20.04:LTS
- Versions du logiciel
- 1.1.1f-1ubuntu2.fips.2.8
- 1.1.1f-1ubuntu2.fips.7.1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
openssl Ubuntu:22.04:LTS
- Plages de versions concernées
- ECOSYSTEM: < 1.1.1l-1ubuntu1
Mettez à jour vers 1.1.1l-1ubuntu1
Sources originales
- https://www.openssl.org/news/secadv/20210824.txt
- https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=59f5e75f3bced8fc0e130d72a3f582cf7b480b46
- https://www.debian.org/security/2021/dsa-4963
- https://lists.apache.org/thread.html/r18995de860f0e63635f3008fd2a6aca82394249476d21691e7c59c9e%40%3Cdev.tomcat.apache.org%3E
- http://www.openwall.com/lists/oss-security/2021/08/26/2
- https://lists.apache.org/thread.html/rad5d9f83f0d11fb3f8bb148d179b8a9ad7c6a17f18d70e5805a713d1%40%3Cdev.tomcat.apache.org%3E
- https://security.netapp.com/advisory/ntap-20210827-0010/
- https://www.oracle.com/security-alerts/cpuoct2021.html
- https://www.tenable.com/security/tns-2021-16
- https://www.oracle.com/security-alerts/cpujan2022.html
- https://security.netapp.com/advisory/ntap-20211022-0003/
- https://www.tenable.com/security/tns-2022-02
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://cert-portal.siemens.com/productcert/pdf/ssa-389290.pdf
- https://security.gentoo.org/glsa/202209-02
- https://security.gentoo.org/glsa/202210-02
- https://security.netapp.com/advisory/ntap-20240621-0006/
- https://nvd.nist.gov/vuln/detail/CVE-2021-3711