CVE-2021-40528
CVE-2021-40528
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
The ElGamal implementation in Libgcrypt before 1.9.4 allows plaintext recovery because, during interaction between two cryptographic libraries, a certain dangerous combination of the prime defined by the receiver's public key, the generator defined by the receiver's public key, and the sender's ephemeral exponents can lead to a cross-configuration attack against OpenPGP.
CVSS 5.9 · Moyenne · EPSS 1,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
n/a
- Versions du logiciel
- n/a: Concernée
Aucun correctif publié
libgcrypt20 Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 1.8.7-6
Mettez à jour vers 1.8.7-6
libgcrypt20 Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 1.8.7-6
Mettez à jour vers 1.8.7-6
libgcrypt20 Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 1.8.7-6
Mettez à jour vers 1.8.7-6
libgcrypt20 Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 1.6.3-2ubuntu1
- 1.6.4-3
- 1.6.4-4
- 1.6.4-5
- 1.6.5-2
- 1.6.5-2ubuntu0.2
- 1.6.5-2ubuntu0.3
- 1.6.5-2ubuntu0.4
- 1.6.5-2ubuntu0.5
- 1.6.5-2ubuntu0.6
- Plages de versions concernées
- ECOSYSTEM: < 1.6.5-2ubuntu0.6+esm1
Mettez à jour vers 1.6.5-2ubuntu0.6+esm1
libgcrypt20 Ubuntu:18.04:LTS
- Versions du logiciel
- 1.7.8-2ubuntu1
- 1.7.9-1
- 1.8.1-4
- 1.8.1-4ubuntu1
- 1.8.1-4ubuntu1.1
- 1.8.1-4ubuntu1.2
- Plages de versions concernées
- ECOSYSTEM: < 1.8.1-4ubuntu1.3
Mettez à jour vers 1.8.1-4ubuntu1.3
libgcrypt20 Ubuntu:Pro:FIPS-updates:18.04:LTS
- Versions du logiciel
- 1.8.1-4ubuntu1.fips.2.4
- 1.8.1-4ubuntu1.fips.2.5
- Plages de versions concernées
- ECOSYSTEM: < 1.8.1-4ubuntu1.fips.3
Mettez à jour vers 1.8.1-4ubuntu1.fips.3
libgcrypt20 Ubuntu:Pro:FIPS:18.04:LTS
- Versions du logiciel
- 1.8.1-4ubuntu1.fips.2.4
- 1.8.1-4ubuntu1.fips.2.5
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
libgcrypt20 Ubuntu:20.04:LTS
- Versions du logiciel
- 1.8.4-5ubuntu2
- 1.8.5-3ubuntu1
- 1.8.5-5ubuntu1
- Plages de versions concernées
- ECOSYSTEM: < 1.8.5-5ubuntu1.1
Mettez à jour vers 1.8.5-5ubuntu1.1
libgcrypt20 Ubuntu:Pro:FIPS-updates:20.04:LTS
- Plages de versions concernées
- ECOSYSTEM: < 1.8.5-5ubuntu1.fips.1.1
Mettez à jour vers 1.8.5-5ubuntu1.fips.1.1
libgcrypt20 Ubuntu:Pro:FIPS:20.04:LTS
- Plages de versions concernées
- ECOSYSTEM: < 1.8.5-5ubuntu1.fips.1.1
Mettez à jour vers 1.8.5-5ubuntu1.fips.1.1
libgcrypt20 Ubuntu:22.04:LTS
- Plages de versions concernées
- ECOSYSTEM: < 1.8.7-5ubuntu2
Mettez à jour vers 1.8.7-5ubuntu2
Sources originales
- https://eprint.iacr.org/2021/923
- https://ibm.github.io/system-security-research-updates/2021/07/20/insecurity-elgamal-pt1
- https://ibm.github.io/system-security-research-updates/2021/09/06/insecurity-elgamal-pt2
- https://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgcrypt.git%3Ba=commit%3Bh=3462280f2e23e16adf3ed5176e0f2413d8861320
- https://security.gentoo.org/glsa/202210-13
- https://nvd.nist.gov/vuln/detail/CVE-2021-40528