p PatchFirst

CVE-2021-4231

CVE-2021-4231 · Angular Comment cross site scripting

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2. It has been classified as problematic. Affected is the handling of comments. The manipulation leads to cross site scripting. It is possible to launch the attack remotely but it might require an authentication first. Upgrading to version 11.0.5 and 11.1.0-next.3 is able to address this issue. The name of the patch is ba8da742e3b243e8f43d4c63aa842b44e14f2b09. It is recommended to upgrade the affected component.

CVSS 3.5 · Faible · EPSS 1,2% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • angular

    Versions du logiciel
    • 11.0.0: Concernée
    • 11.0.1: Concernée
    • 11.0.2: Concernée
    • 11.0.3: Concernée
    • 11.0.4: Concernée
    • 11.1.0-next.0: Concernée
    • 11.1.0-next.1: Concernée
    • 11.1.0-next.2: Concernée

    Aucun correctif publié

  • @angular/core npm

    Plages de versions concernées
    • SEMVER: ≥ 11.0.0, < 11.0.5

    Mettez à jour vers 11.0.5

  • @angular/core npm

    Plages de versions concernées
    • SEMVER: ≥ 11.1.0-next.0, < 11.1.0-next.3

    Mettez à jour vers 11.1.0-next.3

  • @angular/core npm

    Plages de versions concernées
    • SEMVER: < 10.2.5

    Mettez à jour vers 10.2.5

Sources originales

Vérifiez votre serveur →