CVE-2021-43816
CVE-2021-43816 · Improper Preservation of Permissions in containerd
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
containerd is an open source container runtime. On installations using SELinux, such as EL8 (CentOS, RHEL), Fedora, or SUSE MicroOS, with containerd since v1.5.0-beta.0 as the backing container runtime interface (CRI), an unprivileged pod scheduled to the node may bind mount, via hostPath volume, any privileged, regular file on disk for complete read/write access (sans delete). Such is achieved by placing the in-container location of the hostPath volume mount at either `/etc/hosts`, `/etc/hostname`, or `/etc/resolv.conf`. These locations are being relabeled indiscriminately to match the container process-label which effectively elevates permissions for savvy containers that would not normally be able to access privileged host files. This issue has been resolved in version 1.5.9. Users are advised to upgrade as soon as possible.
CVSS 8.0 · Élevée · EPSS 1,7% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · containers
Produits et versions concernés
containerd
- Versions du logiciel
- >= 1.5.0, < 1.5.9: Concernée
Aucun correctif publié
containerd Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 1.5.9~ds1-1
Mettez à jour vers 1.5.9~ds1-1
containerd Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 1.5.9~ds1-1
Mettez à jour vers 1.5.9~ds1-1
containerd Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 1.5.9~ds1-1
Mettez à jour vers 1.5.9~ds1-1
containerd Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 0.2.1-0ubuntu4~16.04
- 0.2.3-0ubuntu1~16.04
- 0.2.5-0ubuntu1~16.04.1
- 1.2.6-0ubuntu1~16.04.2
- 1.2.6-0ubuntu1~16.04.3
- 1.2.6-0ubuntu1~16.04.4
- 1.2.6-0ubuntu1~16.04.5
- 1.2.6-0ubuntu1~16.04.6
- 1.2.6-0ubuntu1~16.04.6+esm1
- 1.2.6-0ubuntu1~16.04.6+esm2
- 1.2.6-0ubuntu1~16.04.6+esm4
- 1.2.6-0ubuntu1~16.04.6+esm5
- 1.2.6-0ubuntu1~16.04.6+esm6
- 1.2.6-0ubuntu1~16.04.6+esm7
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
containerd Ubuntu:18.04:LTS
- Versions du logiciel
- 0.2.5-0ubuntu2
- 1.2.6-0ubuntu1~18.04.1
- 1.2.6-0ubuntu1~18.04.2
- 1.3.3-0ubuntu1~18.04.1
- 1.3.3-0ubuntu1~18.04.2
- 1.3.3-0ubuntu1~18.04.3
- 1.3.3-0ubuntu1~18.04.4
- 1.4.4-0ubuntu1~18.04.2
- 1.5.2-0ubuntu1~18.04.1
- 1.5.2-0ubuntu1~18.04.2
- 1.5.2-0ubuntu1~18.04.3
- 1.5.5-0ubuntu3~18.04.1
- 1.5.5-0ubuntu3~18.04.2
- Plages de versions concernées
- ECOSYSTEM: < 1.5.9-0ubuntu1~18.04.1
Mettez à jour vers 1.5.9-0ubuntu1~18.04.1
containerd Ubuntu:20.04:LTS
- Versions du logiciel
- 1.2.10-0ubuntu1
- 1.3.2-0ubuntu1
- 1.3.3-0ubuntu1
- 1.3.3-0ubuntu2
- 1.3.3-0ubuntu2.1
- 1.3.3-0ubuntu2.2
- 1.3.3-0ubuntu2.3
- 1.4.4-0ubuntu1~20.04.2
- 1.5.2-0ubuntu1~20.04.1
- 1.5.2-0ubuntu1~20.04.2
- 1.5.2-0ubuntu1~20.04.3
- 1.5.5-0ubuntu3~20.04.1
- 1.5.5-0ubuntu3~20.04.2
- 1.5.9-0ubuntu1~20.04.1
- Plages de versions concernées
- ECOSYSTEM: < 1.5.9-0ubuntu1~20.04.4
Mettez à jour vers 1.5.9-0ubuntu1~20.04.4
containerd Ubuntu:22.04:LTS
- Versions du logiciel
- 1.5.5-0ubuntu3
- Plages de versions concernées
- ECOSYSTEM: < 1.5.9-0ubuntu1
Mettez à jour vers 1.5.9-0ubuntu1
Sources originales
- https://github.com/containerd/containerd/security/advisories/GHSA-mvff-h3cj-wj9c
- https://github.com/containerd/containerd/issues/6194
- https://github.com/containerd/containerd/commit/a731039238c62be081eb8c31525b988415745eea
- https://github.com/dweomer/containerd/commit/f7f08f0e34fb97392b0d382e58916d6865100299
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GD5GH7NMK5VJMA2Y5CYB5O5GTPYMWMLX/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MPDIZMI7ZPERSZE2XO265UCK5IWM7CID/
- https://nvd.nist.gov/vuln/detail/CVE-2021-43816