CVE-2022-24712
CVE-2022-24712 · Cross-Site Request Forgery (CSRF) Protection Bypass Vulnerability in CodeIgniter4
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
CodeIgniter4 is the 4.x branch of CodeIgniter, a PHP full-stack web framework. A vulnerability in versions prior to 4.1.9 might allow remote attackers to bypass the CodeIgniter4 Cross-Site Request Forgery (CSRF) protection mechanism. Users should upgrade to version 4.1.9. There are workarounds for this vulnerability, but users will still need to code as these after upgrading to v4.1.9. Otherwise, the CSRF protection may be bypassed. If auto-routing is enabled, check the request method in the controller method before processing. If auto-routing is disabled, either avoid using `$routes->add()` and instead use HTTP verbs in routes; or check the request method in the controller method before processing.
CVSS 6.3 · Moyenne · EPSS 0,6% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: php
Produits et versions concernés
codeigniter4
- Versions du logiciel
- < 4.1.9: Concernée
Aucun correctif publié
codeigniter4/framework Packagist
- Versions du logiciel
- 4.0.0
- 4.0.0-rc.4
- v4.0.0-alpha.3
- v4.0.0-alpha.4
- v4.0.0-alpha.5
- v4.0.0-beta.1
- v4.0.0-beta.2
- v4.0.0-beta.3
- v4.0.0-beta.4
- v4.0.0-rc.1
- v4.0.0-rc.2
- v4.0.0-rc.2.1
- v4.0.0-rc.3
- v4.0.1
- v4.0.2
- v4.0.3
- v4.0.4
- v4.0.5
- v4.1.0
- v4.1.1
- v4.1.2
- v4.1.3
- v4.1.4
- v4.1.5
- v4.1.6
- v4.1.7
- v4.1.8
- Plages de versions concernées
- ECOSYSTEM: < 4.1.9
Mettez à jour vers 4.1.9