p PatchFirst

CVE-2022-24769

CVE-2022-24769 · Default inheritable capabilities for linux container should be empty

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Moby is an open-source project created by Docker to enable and accelerate software containerization. A bug was found in Moby (Docker Engine) prior to version 20.10.14 where containers were incorrectly started with non-empty inheritable Linux process capabilities, creating an atypical Linux environment and enabling programs with inheritable file capabilities to elevate those capabilities to the permitted set during `execve(2)`. Normally, when executable programs have specified permitted file capabilities, otherwise unprivileged users and processes can execute those programs and gain the specified file capabilities up to the bounding set. Due to this bug, containers which included executable programs with inheritable file capabilities allowed otherwise unprivileged users and processes to additionally gain these inheritable file capabilities up to the container's bounding set. Containers which use Linux users and groups to perform privilege separation inside the container are most directly impacted. This bug did not affect the container security sandbox as the inheritable set never contained more capabilities than were included in the container's bounding set. This bug has been fixed in Moby (Docker Engine) 20.10.14. Running containers should be stopped, deleted, and recreated for the inheritable capabilities to be reset. This fix changes Moby (Docker Engine) behavior such that containers are started with a more typical Linux environment. As a workaround, the entry point of a container can be modified to use a utility like `capsh(1)` to drop inheritable capabilities prior to the primary process starting.

CVSS 5.9 · Moyenne · EPSS 0,5% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · containers

Produits et versions concernés

  • docker engine

    Versions du logiciel
    • < 20.10.14: Concernée

    Aucun correctif publié

  • containerd Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 1.6.2~ds1-1

    Mettez à jour vers 1.6.2~ds1-1

  • containerd Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 1.6.2~ds1-1

    Mettez à jour vers 1.6.2~ds1-1

  • containerd Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 1.6.2~ds1-1

    Mettez à jour vers 1.6.2~ds1-1

  • containerd Ubuntu:Pro:16.04:LTS

    Versions du logiciel
    • 0.2.1-0ubuntu4~16.04
    • 0.2.3-0ubuntu1~16.04
    • 0.2.5-0ubuntu1~16.04.1
    • 1.2.6-0ubuntu1~16.04.2
    • 1.2.6-0ubuntu1~16.04.3
    • 1.2.6-0ubuntu1~16.04.4
    • 1.2.6-0ubuntu1~16.04.5
    • 1.2.6-0ubuntu1~16.04.6
    • 1.2.6-0ubuntu1~16.04.6+esm1
    • 1.2.6-0ubuntu1~16.04.6+esm2
    • 1.2.6-0ubuntu1~16.04.6+esm4
    • 1.2.6-0ubuntu1~16.04.6+esm5
    • 1.2.6-0ubuntu1~16.04.6+esm6
    • 1.2.6-0ubuntu1~16.04.6+esm7
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • containerd Ubuntu:18.04:LTS

    Versions du logiciel
    • 0.2.5-0ubuntu2
    • 1.2.6-0ubuntu1~18.04.1
    • 1.2.6-0ubuntu1~18.04.2
    • 1.3.3-0ubuntu1~18.04.1
    • 1.3.3-0ubuntu1~18.04.2
    • 1.3.3-0ubuntu1~18.04.3
    • 1.3.3-0ubuntu1~18.04.4
    • 1.4.4-0ubuntu1~18.04.2
    • 1.5.2-0ubuntu1~18.04.1
    • 1.5.2-0ubuntu1~18.04.2
    • 1.5.2-0ubuntu1~18.04.3
    • 1.5.5-0ubuntu3~18.04.1
    • 1.5.5-0ubuntu3~18.04.2
    • 1.5.9-0ubuntu1~18.04.1
    Plages de versions concernées
    • ECOSYSTEM: < 1.5.9-0ubuntu1~18.04.2

    Mettez à jour vers 1.5.9-0ubuntu1~18.04.2

  • containerd Ubuntu:20.04:LTS

    Versions du logiciel
    • 1.2.10-0ubuntu1
    • 1.3.2-0ubuntu1
    • 1.3.3-0ubuntu1
    • 1.3.3-0ubuntu2
    • 1.3.3-0ubuntu2.1
    • 1.3.3-0ubuntu2.2
    • 1.3.3-0ubuntu2.3
    • 1.4.4-0ubuntu1~20.04.2
    • 1.5.2-0ubuntu1~20.04.1
    • 1.5.2-0ubuntu1~20.04.2
    • 1.5.2-0ubuntu1~20.04.3
    • 1.5.5-0ubuntu3~20.04.1
    • 1.5.5-0ubuntu3~20.04.2
    • 1.5.9-0ubuntu1~20.04.1
    • 1.5.9-0ubuntu1~20.04.4
    • 1.5.9-0ubuntu1~20.04.5
    Plages de versions concernées
    • ECOSYSTEM: < 1.5.9-0ubuntu1~20.04.6

    Mettez à jour vers 1.5.9-0ubuntu1~20.04.6

  • containerd Ubuntu:22.04:LTS

    Versions du logiciel
    • 1.5.5-0ubuntu3
    • 1.5.9-0ubuntu1
    • 1.5.9-0ubuntu2
    • 1.5.9-0ubuntu3
    Plages de versions concernées
    • ECOSYSTEM: < 1.5.9-0ubuntu3.1

    Mettez à jour vers 1.5.9-0ubuntu3.1

Sources originales

Vérifiez votre serveur →