CVE-2022-27776
CVE-2022-27776
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
A insufficiently protected credentials vulnerability in fixed in curl 7.83.0 might leak authentication or cookie header data on HTTP redirects to the same host but another port number.
CVSS 6.5 · Moyenne · EPSS 4,1% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
https://github.com/curl/curl
- Versions du logiciel
- fixed in curl 7.83.0: Concernée
Aucun correctif publié
curl Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 7.83.0-1
Mettez à jour vers 7.83.0-1
curl Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 7.83.0-1
Mettez à jour vers 7.83.0-1
curl Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 7.83.0-1
Mettez à jour vers 7.83.0-1
curl Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 7.32.0-1ubuntu1
- 7.33.0-1ubuntu1
- 7.34.0-1ubuntu1
- 7.35.0-1ubuntu1
- 7.35.0-1ubuntu2
- 7.35.0-1ubuntu2.1
- 7.35.0-1ubuntu2.2
- 7.35.0-1ubuntu2.3
- 7.35.0-1ubuntu2.5
- 7.35.0-1ubuntu2.6
- 7.35.0-1ubuntu2.7
- 7.35.0-1ubuntu2.8
- 7.35.0-1ubuntu2.9
- 7.35.0-1ubuntu2.10
- 7.35.0-1ubuntu2.11
- 7.35.0-1ubuntu2.12
- 7.35.0-1ubuntu2.13
- 7.35.0-1ubuntu2.14
- 7.35.0-1ubuntu2.15
- 7.35.0-1ubuntu2.16
- 7.35.0-1ubuntu2.17
- 7.35.0-1ubuntu2.19
- 7.35.0-1ubuntu2.20
- 7.35.0-1ubuntu2.20+esm2
- 7.35.0-1ubuntu2.20+esm3
- 7.35.0-1ubuntu2.20+esm4
- 7.35.0-1ubuntu2.20+esm5
- 7.35.0-1ubuntu2.20+esm6
- 7.35.0-1ubuntu2.20+esm7
- 7.35.0-1ubuntu2.20+esm8
- 7.35.0-1ubuntu2.20+esm9
- 7.35.0-1ubuntu2.20+esm10
- 7.35.0-1ubuntu2.20+esm11
- 7.35.0-1ubuntu2.20+esm12
- 7.35.0-1ubuntu2.20+esm13
- 7.35.0-1ubuntu2.20+esm14
- 7.35.0-1ubuntu2.20+esm15
- 7.35.0-1ubuntu2.20+esm16
- 7.35.0-1ubuntu2.20+esm17
- 7.35.0-1ubuntu2.20+esm18
- 7.35.0-1ubuntu2.20+esm19
- 7.35.0-1ubuntu2.20+esm20
- 7.35.0-1ubuntu2.20+esm21
- 7.35.0-1ubuntu2.20+esm22
- 7.35.0-1ubuntu2.20+esm23
- 7.35.0-1ubuntu2.20+esm24
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
curl Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 7.43.0-1ubuntu2
- 7.45.0-1ubuntu1
- 7.46.0-1ubuntu1
- 7.47.0-1ubuntu1
- 7.47.0-1ubuntu2
- 7.47.0-1ubuntu2.1
- 7.47.0-1ubuntu2.2
- 7.47.0-1ubuntu2.3
- 7.47.0-1ubuntu2.4
- 7.47.0-1ubuntu2.5
- 7.47.0-1ubuntu2.6
- 7.47.0-1ubuntu2.7
- 7.47.0-1ubuntu2.8
- 7.47.0-1ubuntu2.9
- 7.47.0-1ubuntu2.11
- 7.47.0-1ubuntu2.12
- 7.47.0-1ubuntu2.13
- 7.47.0-1ubuntu2.14
- 7.47.0-1ubuntu2.15
- 7.47.0-1ubuntu2.16
- 7.47.0-1ubuntu2.18
- 7.47.0-1ubuntu2.19
- 7.47.0-1ubuntu2.19+esm1
- 7.47.0-1ubuntu2.19+esm2
- 7.47.0-1ubuntu2.19+esm3
- 7.47.0-1ubuntu2.19+esm4
- 7.47.0-1ubuntu2.19+esm5
- 7.47.0-1ubuntu2.19+esm6
- 7.47.0-1ubuntu2.19+esm7
- 7.47.0-1ubuntu2.19+esm8
- 7.47.0-1ubuntu2.19+esm9
- 7.47.0-1ubuntu2.19+esm10
- 7.47.0-1ubuntu2.19+esm11
- 7.47.0-1ubuntu2.19+esm12
- 7.47.0-1ubuntu2.19+esm13
- 7.47.0-1ubuntu2.19+esm15
- 7.47.0-1ubuntu2.19+esm16
- 7.47.0-1ubuntu2.19+esm17
- 7.47.0-1ubuntu2.19+esm18
- 7.47.0-1ubuntu2.19+esm20
- 7.47.0-1ubuntu2.19+esm21
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
curl Ubuntu:18.04:LTS
- Versions du logiciel
- 7.55.1-1ubuntu2
- 7.55.1-1ubuntu2.1
- 7.57.0-1ubuntu1
- 7.58.0-2ubuntu1
- 7.58.0-2ubuntu2
- 7.58.0-2ubuntu3
- 7.58.0-2ubuntu3.1
- 7.58.0-2ubuntu3.2
- 7.58.0-2ubuntu3.3
- 7.58.0-2ubuntu3.5
- 7.58.0-2ubuntu3.6
- 7.58.0-2ubuntu3.7
- 7.58.0-2ubuntu3.8
- 7.58.0-2ubuntu3.9
- 7.58.0-2ubuntu3.10
- 7.58.0-2ubuntu3.12
- 7.58.0-2ubuntu3.13
- 7.58.0-2ubuntu3.14
- 7.58.0-2ubuntu3.15
- 7.58.0-2ubuntu3.16
- Plages de versions concernées
- ECOSYSTEM: < 7.58.0-2ubuntu3.17
Mettez à jour vers 7.58.0-2ubuntu3.17
curl Ubuntu:20.04:LTS
- Versions du logiciel
- 7.65.3-1ubuntu3
- 7.65.3-1ubuntu4
- 7.66.0-1ubuntu1
- 7.67.0-2ubuntu1
- 7.68.0-1ubuntu1
- 7.68.0-1ubuntu2
- 7.68.0-1ubuntu2.1
- 7.68.0-1ubuntu2.2
- 7.68.0-1ubuntu2.4
- 7.68.0-1ubuntu2.5
- 7.68.0-1ubuntu2.6
- 7.68.0-1ubuntu2.7
- Plages de versions concernées
- ECOSYSTEM: < 7.68.0-1ubuntu2.10
Mettez à jour vers 7.68.0-1ubuntu2.10
curl Ubuntu:22.04:LTS
- Versions du logiciel
- 7.74.0-1.3ubuntu2
- 7.74.0-1.3ubuntu3
- 7.80.0-3
- 7.81.0-1
- Plages de versions concernées
- ECOSYSTEM: < 7.81.0-1ubuntu1.1
Mettez à jour vers 7.81.0-1ubuntu1.1
Sources originales
- https://hackerone.com/reports/1547048
- https://security.netapp.com/advisory/ntap-20220609-0008/
- https://www.debian.org/security/2022/dsa-5197
- https://lists.debian.org/debian-lts-announce/2022/08/msg00017.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7N5ZBWLNNPZKFK7Q4KEHGCJ2YELQEUJP/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DKKOQXPYLMBSEVDHFS32BPBR3ZQJKY5B/
- https://security.gentoo.org/glsa/202212-01
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
- https://nvd.nist.gov/vuln/detail/CVE-2022-27776