CVE-2022-29162
CVE-2022-29162 · Incorrect Default Permissions in runc
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
runc is a CLI tool for spawning and running containers on Linux according to the OCI specification. A bug was found in runc prior to version 1.1.2 where `runc exec --cap` created processes with non-empty inheritable Linux process capabilities, creating an atypical Linux environment and enabling programs with inheritable file capabilities to elevate those capabilities to the permitted set during execve(2). This bug did not affect the container security sandbox as the inheritable set never contained more capabilities than were included in the container's bounding set. This bug has been fixed in runc 1.1.2. This fix changes `runc exec --cap` behavior such that the additional capabilities granted to the process being executed (as specified via `--cap` arguments) do not include inheritable capabilities. In addition, `runc spec` is changed to not set any inheritable capabilities in the created example OCI spec (`config.json`) file.
CVSS 5.9 · Moyenne · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · containers
Produits et versions concernés
runc
- Versions du logiciel
- < 1.1.2: Concernée
Aucun correctif publié
runc Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 1.1.3+ds1-1
Mettez à jour vers 1.1.3+ds1-1
runc Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 1.1.3+ds1-1
Mettez à jour vers 1.1.3+ds1-1
runc Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 1.1.3+ds1-1
Mettez à jour vers 1.1.3+ds1-1
runc Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 0.0.8+dfsg-2
- 0.1.1-0ubuntu5~16.04
- 1.0.0~rc1-0ubuntu1~16.04
- 1.0.0~rc1-0ubuntu2~16.04.1
- 1.0.0~rc1-0ubuntu2~16.04.1.1
- 1.0.0~rc2-0ubuntu2~16.04.1
- 1.0.0~rc2+docker1.12.6-0ubuntu1~16.04.1
- 1.0.0~rc2+docker1.13.1-0ubuntu1~16.04.1
- 1.0.0~rc2+docker1.13.1-0ubuntu1~16.04.2
- 1.0.0~rc7+git20190403.029124da-0ubuntu1~16.04.3
- 1.0.0~rc7+git20190403.029124da-0ubuntu1~16.04.4
- 1.0.0~rc7+git20190403.029124da-0ubuntu1~16.04.4+esm1
- 1.0.0~rc7+git20190403.029124da-0ubuntu1~16.04.4+esm2
- Plages de versions concernées
- ECOSYSTEM: < 1.0.0~rc7+git20190403.029124da-0ubuntu1~16.04.4+esm4
Mettez à jour vers 1.0.0~rc7+git20190403.029124da-0ubuntu1~16.04.4+esm4
Sources originales
- https://github.com/opencontainers/runc/security/advisories/GHSA-f3fp-gc8g-vw66
- https://github.com/opencontainers/runc/commit/d04de3a9b72d7a2455c1885fc75eb36d02cd17b5
- https://github.com/opencontainers/runc/releases/tag/v1.1.2
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/D77CKD3AXPMU4PMQIQI5Q74SI4JATNND/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GPQU4YC4AAY54JDXGDQHJEYKSXXG5T2Y/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/AVPZBV7ISA7QKRPTC7ZXWKMIQI2HZEBB/
- https://lists.debian.org/debian-lts-announce/2023/03/msg00023.html
- https://nvd.nist.gov/vuln/detail/CVE-2022-29162