CVE-2022-31181
CVE-2022-31181 · Remote code execution in prestashop
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
PrestaShop is an Open Source e-commerce platform. In versions from 1.6.0.10 and before 1.7.8.7 PrestaShop is subject to an SQL injection vulnerability which can be chained to call PHP's Eval function on attacker input. The problem is fixed in version 1.7.8.7. Users are advised to upgrade. Users unable to upgrade may delete the MySQL Smarty cache feature.
CVSS 9.8 · Critique · EPSS 6,7% · Code d’exploitation public · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: php
Produits et versions concernés
prestashop
- Versions du logiciel
- >= 1.6.0.10, < 1.7.8.7: Concernée
Aucun correctif publié
prestashop/prestashop Packagist
- Versions du logiciel
- 1.7.0.0
- 1.7.0.0-beta.1.0
- 1.7.0.0-beta.2.0
- 1.7.0.0-beta.3.0
- 1.7.0.0-beta.4.0
- 1.7.0.0-rc.0.0
- 1.7.0.0-rc.1.0
- 1.7.0.0-rc.2.0
- 1.7.0.1
- 1.7.0.2
- 1.7.0.3
- 1.7.0.4
- 1.7.0.5
- 1.7.0.6
- 1.7.1.0
- 1.7.1.1
- 1.7.1.2
- 1.7.2.0
- 1.7.2.0-rc.1.0
- 1.7.2.1
- 1.7.2.2
- 1.7.2.3
- 1.7.2.4
- 1.7.2.5
- 1.7.3.0
- 1.7.3.1
- 1.7.3.2
- 1.7.3.3
- 1.7.3.4
- 1.7.4.0
- 1.7.4.0-beta.1
- 1.7.4.1
- 1.7.4.2
- 1.7.4.3
- 1.7.4.4
- 1.7.5.0
- 1.7.5.0-beta.1
- 1.7.5.0-rc.1
- 1.7.5.1
- 1.7.5.2
- 1.7.6.0
- 1.7.6.0-beta.1
- 1.7.6.0-rc.1
- 1.7.6.0-rc.2
- 1.7.6.1
- 1.7.6.2
- 1.7.6.3
- 1.7.6.4
- 1.7.6.5
- 1.7.6.6
- 1.7.6.7
- 1.7.6.8
- 1.7.6.9
- 1.7.7.0
- 1.7.7.0-beta.1
- 1.7.7.0-beta.2
- 1.7.7.0-rc.1
- 1.7.7.1
- 1.7.7.2
- 1.7.7.3
- 1.7.7.4
- 1.7.7.5
- 1.7.7.6
- 1.7.7.7
- 1.7.7.8
- 1.7.8.0
- 1.7.8.0-beta.1
- 1.7.8.0-rc.1
- 1.7.8.1
- 1.7.8.2
- 1.7.8.3
- 1.7.8.4
- 1.7.8.5
- 1.7.8.6
- Plages de versions concernées
- ECOSYSTEM: ≥ 1.6.0.10, < 1.7.8.7
Mettez à jour vers 1.7.8.7