CVE-2022-32221
CVE-2022-32221
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
When doing HTTP(S) transfers, libcurl might erroneously use the read callback (`CURLOPT_READFUNCTION`) to ask for data to send, even when the `CURLOPT_POSTFIELDS` option has been set, if the same handle previously was used to issue a `PUT` request which used that callback. This flaw may surprise the application and cause it to misbehave and either send off the wrong data or use memory after free or similar in the subsequent `POST` request. The problem exists in the logic for a reused handle when it is changed from a PUT to a POST.
CVSS 9.8 · Critique · EPSS 5,1% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
https://github.com/curl/curl
- Versions du logiciel
- Fixed in 7.86.0: Concernée
Aucun correctif publié
curl Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 7.86.0-1
Mettez à jour vers 7.86.0-1
curl Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 7.86.0-1
Mettez à jour vers 7.86.0-1
curl Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 7.86.0-1
Mettez à jour vers 7.86.0-1
curl Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 7.32.0-1ubuntu1
- 7.33.0-1ubuntu1
- 7.34.0-1ubuntu1
- 7.35.0-1ubuntu1
- 7.35.0-1ubuntu2
- 7.35.0-1ubuntu2.1
- 7.35.0-1ubuntu2.2
- 7.35.0-1ubuntu2.3
- 7.35.0-1ubuntu2.5
- 7.35.0-1ubuntu2.6
- 7.35.0-1ubuntu2.7
- 7.35.0-1ubuntu2.8
- 7.35.0-1ubuntu2.9
- 7.35.0-1ubuntu2.10
- 7.35.0-1ubuntu2.11
- 7.35.0-1ubuntu2.12
- 7.35.0-1ubuntu2.13
- 7.35.0-1ubuntu2.14
- 7.35.0-1ubuntu2.15
- 7.35.0-1ubuntu2.16
- 7.35.0-1ubuntu2.17
- 7.35.0-1ubuntu2.19
- 7.35.0-1ubuntu2.20
- 7.35.0-1ubuntu2.20+esm2
- 7.35.0-1ubuntu2.20+esm3
- 7.35.0-1ubuntu2.20+esm4
- 7.35.0-1ubuntu2.20+esm5
- 7.35.0-1ubuntu2.20+esm6
- 7.35.0-1ubuntu2.20+esm7
- 7.35.0-1ubuntu2.20+esm8
- 7.35.0-1ubuntu2.20+esm9
- 7.35.0-1ubuntu2.20+esm10
- 7.35.0-1ubuntu2.20+esm11
- 7.35.0-1ubuntu2.20+esm12
- Plages de versions concernées
- ECOSYSTEM: < 7.35.0-1ubuntu2.20+esm13
Mettez à jour vers 7.35.0-1ubuntu2.20+esm13
curl Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 7.43.0-1ubuntu2
- 7.45.0-1ubuntu1
- 7.46.0-1ubuntu1
- 7.47.0-1ubuntu1
- 7.47.0-1ubuntu2
- 7.47.0-1ubuntu2.1
- 7.47.0-1ubuntu2.2
- 7.47.0-1ubuntu2.3
- 7.47.0-1ubuntu2.4
- 7.47.0-1ubuntu2.5
- 7.47.0-1ubuntu2.6
- 7.47.0-1ubuntu2.7
- 7.47.0-1ubuntu2.8
- 7.47.0-1ubuntu2.9
- 7.47.0-1ubuntu2.11
- 7.47.0-1ubuntu2.12
- 7.47.0-1ubuntu2.13
- 7.47.0-1ubuntu2.14
- 7.47.0-1ubuntu2.15
- 7.47.0-1ubuntu2.16
- 7.47.0-1ubuntu2.18
- 7.47.0-1ubuntu2.19
- 7.47.0-1ubuntu2.19+esm1
- 7.47.0-1ubuntu2.19+esm2
- 7.47.0-1ubuntu2.19+esm3
- 7.47.0-1ubuntu2.19+esm4
- 7.47.0-1ubuntu2.19+esm5
- Plages de versions concernées
- ECOSYSTEM: < 7.47.0-1ubuntu2.19+esm6
Mettez à jour vers 7.47.0-1ubuntu2.19+esm6
curl Ubuntu:18.04:LTS
- Versions du logiciel
- 7.55.1-1ubuntu2
- 7.55.1-1ubuntu2.1
- 7.57.0-1ubuntu1
- 7.58.0-2ubuntu1
- 7.58.0-2ubuntu2
- 7.58.0-2ubuntu3
- 7.58.0-2ubuntu3.1
- 7.58.0-2ubuntu3.2
- 7.58.0-2ubuntu3.3
- 7.58.0-2ubuntu3.5
- 7.58.0-2ubuntu3.6
- 7.58.0-2ubuntu3.7
- 7.58.0-2ubuntu3.8
- 7.58.0-2ubuntu3.9
- 7.58.0-2ubuntu3.10
- 7.58.0-2ubuntu3.12
- 7.58.0-2ubuntu3.13
- 7.58.0-2ubuntu3.14
- 7.58.0-2ubuntu3.15
- 7.58.0-2ubuntu3.16
- 7.58.0-2ubuntu3.17
- 7.58.0-2ubuntu3.18
- 7.58.0-2ubuntu3.19
- 7.58.0-2ubuntu3.20
- Plages de versions concernées
- ECOSYSTEM: < 7.58.0-2ubuntu3.21
Mettez à jour vers 7.58.0-2ubuntu3.21
curl Ubuntu:20.04:LTS
- Versions du logiciel
- 7.65.3-1ubuntu3
- 7.65.3-1ubuntu4
- 7.66.0-1ubuntu1
- 7.67.0-2ubuntu1
- 7.68.0-1ubuntu1
- 7.68.0-1ubuntu2
- 7.68.0-1ubuntu2.1
- 7.68.0-1ubuntu2.2
- 7.68.0-1ubuntu2.4
- 7.68.0-1ubuntu2.5
- 7.68.0-1ubuntu2.6
- 7.68.0-1ubuntu2.7
- 7.68.0-1ubuntu2.10
- 7.68.0-1ubuntu2.11
- 7.68.0-1ubuntu2.12
- 7.68.0-1ubuntu2.13
- Plages de versions concernées
- ECOSYSTEM: < 7.68.0-1ubuntu2.14
Mettez à jour vers 7.68.0-1ubuntu2.14
curl Ubuntu:22.04:LTS
- Versions du logiciel
- 7.74.0-1.3ubuntu2
- 7.74.0-1.3ubuntu3
- 7.80.0-3
- 7.81.0-1
- 7.81.0-1ubuntu1.1
- 7.81.0-1ubuntu1.2
- 7.81.0-1ubuntu1.3
- 7.81.0-1ubuntu1.4
- Plages de versions concernées
- ECOSYSTEM: < 7.81.0-1ubuntu1.6
Mettez à jour vers 7.81.0-1ubuntu1.6
Sources originales
- https://hackerone.com/reports/1704017
- https://security.gentoo.org/glsa/202212-01
- https://security.netapp.com/advisory/ntap-20230110-0006/
- https://support.apple.com/kb/HT213604
- https://support.apple.com/kb/HT213605
- http://seclists.org/fulldisclosure/2023/Jan/20
- http://seclists.org/fulldisclosure/2023/Jan/19
- https://www.debian.org/security/2023/dsa-5330
- https://lists.debian.org/debian-lts-announce/2023/01/msg00028.html
- https://security.netapp.com/advisory/ntap-20230208-0002/
- http://www.openwall.com/lists/oss-security/2023/05/17/4
- https://cert-portal.siemens.com/productcert/html/ssa-892048.html
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
- https://nvd.nist.gov/vuln/detail/CVE-2022-32221