CVE-2022-3358
CVE-2022-3358 · Using a Custom Cipher with NID_undef may lead to NULL encryption
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
OpenSSL supports creating a custom cipher via the legacy EVP_CIPHER_meth_new() function and associated function calls. This function was deprecated in OpenSSL 3.0 and application authors are instead encouraged to use the new provider mechanism in order to implement custom ciphers. OpenSSL versions 3.0.0 to 3.0.5 incorrectly handle legacy custom ciphers passed to the EVP_EncryptInit_ex2(), EVP_DecryptInit_ex2() and EVP_CipherInit_ex2() functions (as well as other similarly named encryption and decryption initialisation functions). Instead of using the custom cipher directly it incorrectly tries to fetch an equivalent cipher from the available providers. An equivalent cipher is found based on the NID passed to EVP_CIPHER_meth_new(). This NID is supposed to represent the unique NID for a given cipher. However it is possible for an application to incorrectly pass NID_undef as this value in the call to EVP_CIPHER_meth_new(). When NID_undef is used in this way the OpenSSL encryption/decryption initialisation function will match the NULL cipher as being equivalent and will fetch this from the available providers. This will succeed if the default provider has been loaded (or if a third party provider has been loaded that offers this cipher). Using the NULL cipher means that the plaintext is emitted as the ciphertext. Applications are only affected by this issue if they call EVP_CIPHER_meth_new() using NID_undef and subsequently use it in a call to an encryption/decryption initialisation function. Applications that only use SSL/TLS are not impacted by this issue. Fixed in OpenSSL 3.0.6 (Affected 3.0.0-3.0.5).
CVSS 7.5 · Élevée · EPSS 4,0% · Code d’exploitation public · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · network
Produits et versions concernés
openssl
- Versions du logiciel
- Fixed in OpenSSL 3.0.6 (Affected 3.0.0-3.0.5): Concernée
Aucun correctif publié
openssl Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 3.0.7-1
Mettez à jour vers 3.0.7-1
openssl Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 3.0.7-1
Mettez à jour vers 3.0.7-1
openssl Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 3.0.7-1
Mettez à jour vers 3.0.7-1
edk2 Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 0~20150106.5c2d456b-2
- 0~20160104.c2a892d7-1
- 0~20160408.ffea0a2c-2
- 0~20160408.ffea0a2c-2ubuntu0.1
- 0~20160408.ffea0a2c-2ubuntu0.2
- 0~20160408.ffea0a2c-2ubuntu0.2+esm1
- 0~20160408.ffea0a2c-2ubuntu0.2+esm3
- 0~20160408.ffea0a2c-2ubuntu0.2+esm4
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
openssl Ubuntu:22.04:LTS
- Versions du logiciel
- 1.1.1l-1ubuntu1
- 3.0.0-1ubuntu1
- 3.0.1-0ubuntu1
- 3.0.2-0ubuntu1
- 3.0.2-0ubuntu1.1
- 3.0.2-0ubuntu1.2
- 3.0.2-0ubuntu1.4
- 3.0.2-0ubuntu1.5
- 3.0.2-0ubuntu1.6
- Plages de versions concernées
- ECOSYSTEM: < 3.0.2-0ubuntu1.7
Mettez à jour vers 3.0.2-0ubuntu1.7
Sources originales
- https://www.openssl.org/news/secadv/20221011.txt
- https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=5485c56679d7c49b96e8fc8ca708b0b7e7c03c4b
- https://security.netapp.com/advisory/ntap-20221028-0014/
- https://psirt.global.sonicwall.com/vuln-detail/SNWLID-2022-0023
- https://security.gentoo.org/glsa/202402-08
- https://nvd.nist.gov/vuln/detail/CVE-2022-3358