CVE-2022-35977
CVE-2022-35977 · Integer overflow in certain command arguments can drive Redis to OOM panic
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Redis is an in-memory database that persists on disk. Authenticated users issuing specially crafted `SETRANGE` and `SORT(_RO)` commands can trigger an integer overflow, resulting with Redis attempting to allocate impossible amounts of memory and abort with an out-of-memory (OOM) panic. The problem is fixed in Redis versions 7.0.8, 6.2.9 and 6.0.17. Users are advised to upgrade. There are no known workarounds for this vulnerability.
CVSS 5.5 · Moyenne · EPSS 13,5% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · database
Produits et versions concernés
redis
- Versions du logiciel
- >= 7.0, < 7.0.8: Concernée
- >= 6.2, < 6.2.9: Concernée
- < 6.0.17: Concernée
Aucun correctif publié
redis Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 5:7.0.8-1
Mettez à jour vers 5:7.0.8-1
redis Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 5:7.0.8-1
Mettez à jour vers 5:7.0.8-1
redis Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 5:7.0.8-1
Mettez à jour vers 5:7.0.8-1
redis Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 2:2.6.13-1
- 2:2.6.16-3
- 2:2.8.0-1
- 2:2.8.2-1
- 2:2.8.4-2
- 2:2.8.4-2ubuntu0.2
- 2:2.8.4-2ubuntu0.2+esm1
- 2:2.8.4-2ubuntu0.2+esm2
- Plages de versions concernées
- ECOSYSTEM: < 2:2.8.4-2ubuntu0.2+esm3
Mettez à jour vers 2:2.8.4-2ubuntu0.2+esm3
redis Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 2:3.0.3-3
- 2:3.0.5-1
- 2:3.0.5-2
- 2:3.0.5-3
- 2:3.0.5-4
- 2:3.0.6-1
- 2:3.0.6-1ubuntu0.2
- 2:3.0.6-1ubuntu0.3
- 2:3.0.6-1ubuntu0.4
- 2:3.0.6-1ubuntu0.4+esm1
- Plages de versions concernées
- ECOSYSTEM: < 2:3.0.6-1ubuntu0.4+esm2
Mettez à jour vers 2:3.0.6-1ubuntu0.4+esm2
redis Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 4:4.0.1-7
- 4:4.0.2-6
- 4:4.0.2-9
- 5:4.0.5-1
- 5:4.0.6-1
- 5:4.0.6-2
- 5:4.0.7-1
- 5:4.0.8-1
- 5:4.0.8-2
- 5:4.0.9-1
- 5:4.0.9-1ubuntu0.1
- 5:4.0.9-1ubuntu0.2
- 5:4.0.9-1ubuntu0.2+esm2
- 5:4.0.9-1ubuntu0.2+esm3
- Plages de versions concernées
- ECOSYSTEM: < 5:4.0.9-1ubuntu0.2+esm4
Mettez à jour vers 5:4.0.9-1ubuntu0.2+esm4
redis Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 5:5.0.5-2build1
- 5:5.0.6-1
- 5:5.0.7-1
- 5:5.0.7-2
- 5:5.0.7-2ubuntu0.1~esm1
- 5:5.0.7-2ubuntu0.1
- 5:5.0.7-2ubuntu0.1+esm1
- Plages de versions concernées
- ECOSYSTEM: < 5:5.0.7-2ubuntu0.1+esm2
Mettez à jour vers 5:5.0.7-2ubuntu0.1+esm2
redis Ubuntu:Pro:22.04:LTS
- Versions du logiciel
- 5:6.0.15-1
- 5:6.0.16-1
- 5:6.0.16-1build1
- 5:6.0.16-1ubuntu1
- Plages de versions concernées
- ECOSYSTEM: < 5:6.0.16-1ubuntu1+esm1
Mettez à jour vers 5:6.0.16-1ubuntu1+esm1
Sources originales
- https://github.com/redis/redis/security/advisories/GHSA-mrcw-fhw9-fj8j
- https://github.com/redis/redis/commit/1ec82e6e97e1db06a72ca505f9fbf6b981f31ef7
- https://github.com/redis/redis/releases/tag/6.0.17
- https://github.com/redis/redis/releases/tag/6.2.9
- https://github.com/redis/redis/releases/tag/7.0.8
- https://lists.debian.org/debian-lts-announce/2024/11/msg00031.html
- https://nvd.nist.gov/vuln/detail/CVE-2022-35977