CVE-2022-39260
CVE-2022-39260 · Git vulnerable to Remote Code Execution via Heap overflow in `git shell`
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Git is an open source, scalable, distributed revision control system. `git shell` is a restricted login shell that can be used to implement Git's push/pull functionality via SSH. In versions prior to 2.30.6, 2.31.5, 2.32.4, 2.33.5, 2.34.5, 2.35.5, 2.36.3, and 2.37.4, the function that splits the command arguments into an array improperly uses an `int` to represent the number of entries in the array, allowing a malicious actor to intentionally overflow the return value, leading to arbitrary heap writes. Because the resulting array is then passed to `execv()`, it is possible to leverage this attack to gain remote code execution on a victim machine. Note that a victim must first allow access to `git shell` as a login shell in order to be vulnerable to this attack. This problem is patched in versions 2.30.6, 2.31.5, 2.32.4, 2.33.5, 2.34.5, 2.35.5, 2.36.3, and 2.37.4 and users are advised to upgrade to the latest version. Disabling `git shell` access via remote logins is a viable short-term workaround.
CVSS 8.5 · Élevée · EPSS 4,0% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
git
- Versions du logiciel
- < 2.30.6: Concernée
- > 2.31.0, < 2.31.5: Concernée
- > 2.32.0, < 2.32.4: Concernée
- > 2.33.0, < 2.33.5: Concernée
- > 2.34.0, < 2.34.5: Concernée
- > 2.34.0, < 2.35.5: Concernée
- > 2.35.0, < 2.36.3: Concernée
- > 2.37.0, < 2.37.4: Concernée
Aucun correctif publié
git Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 1:2.38.1-1
Mettez à jour vers 1:2.38.1-1
git Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 1:2.38.1-1
Mettez à jour vers 1:2.38.1-1
git Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 1:2.38.1-1
Mettez à jour vers 1:2.38.1-1
git Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 1:2.5.0-1
- 1:2.6.2-1
- 1:2.6.3-1
- 1:2.6.4-1
- 1:2.7.0~rc3-1
- 1:2.7.0-1
- 1:2.7.3-0ubuntu1
- 1:2.7.4-0ubuntu1
- 1:2.7.4-0ubuntu1.1
- 1:2.7.4-0ubuntu1.2
- 1:2.7.4-0ubuntu1.3
- 1:2.7.4-0ubuntu1.4
- 1:2.7.4-0ubuntu1.5
- 1:2.7.4-0ubuntu1.6
- 1:2.7.4-0ubuntu1.7
- 1:2.7.4-0ubuntu1.8
- 1:2.7.4-0ubuntu1.9
- 1:2.7.4-0ubuntu1.10
- 1:2.7.4-0ubuntu1.10+esm1
- Plages de versions concernées
- ECOSYSTEM: < 1:2.7.4-0ubuntu1.10+esm3
Mettez à jour vers 1:2.7.4-0ubuntu1.10+esm3
git Ubuntu:18.04:LTS
- Versions du logiciel
- 1:2.14.1-1ubuntu4
- 1:2.15.1-1ubuntu2
- 1:2.17.0-1ubuntu1
- 1:2.17.1-1ubuntu0.1
- 1:2.17.1-1ubuntu0.3
- 1:2.17.1-1ubuntu0.4
- 1:2.17.1-1ubuntu0.5
- 1:2.17.1-1ubuntu0.6
- 1:2.17.1-1ubuntu0.7
- 1:2.17.1-1ubuntu0.8
- 1:2.17.1-1ubuntu0.9
- 1:2.17.1-1ubuntu0.10
- 1:2.17.1-1ubuntu0.11
- 1:2.17.1-1ubuntu0.12
- Plages de versions concernées
- ECOSYSTEM: < 1:2.17.1-1ubuntu0.13
Mettez à jour vers 1:2.17.1-1ubuntu0.13
git Ubuntu:20.04:LTS
- Versions du logiciel
- 1:2.20.1-2ubuntu1
- 1:2.24.0-1ubuntu1
- 1:2.24.0-1ubuntu2
- 1:2.25.0-1ubuntu1
- 1:2.25.1-1ubuntu1
- 1:2.25.1-1ubuntu2
- 1:2.25.1-1ubuntu3
- 1:2.25.1-1ubuntu3.1
- 1:2.25.1-1ubuntu3.2
- 1:2.25.1-1ubuntu3.3
- 1:2.25.1-1ubuntu3.4
- 1:2.25.1-1ubuntu3.5
- Plages de versions concernées
- ECOSYSTEM: < 1:2.25.1-1ubuntu3.6
Mettez à jour vers 1:2.25.1-1ubuntu3.6
git Ubuntu:22.04:LTS
- Versions du logiciel
- 1:2.32.0-1ubuntu1
- 1:2.33.1-1ubuntu1
- 1:2.34.1-1ubuntu1
- 1:2.34.1-1ubuntu1.1
- 1:2.34.1-1ubuntu1.2
- 1:2.34.1-1ubuntu1.4
- Plages de versions concernées
- ECOSYSTEM: < 1:2.34.1-1ubuntu1.5
Mettez à jour vers 1:2.34.1-1ubuntu1.5
Sources originales
- https://github.com/git/git/security/advisories/GHSA-rjr6-wcq6-83p6
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UKFHE4KVD7EKS5J3KTDFVBEKU3CLXGVV/
- https://support.apple.com/kb/HT213496
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/OHNO2FB55CPX47BAXMBWUBGWHO6N6ZZH/
- http://seclists.org/fulldisclosure/2022/Nov/1
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/C7B6JPKX5CGGLAHXJVQMIZNNEEB72FHD/
- https://lists.debian.org/debian-lts-announce/2022/12/msg00025.html
- https://security.gentoo.org/glsa/202312-15
- https://nvd.nist.gov/vuln/detail/CVE-2022-39260