p PatchFirst

CVE-2022-39284

CVE-2022-39284 · Secure or HttpOnly flag set in Config\Cookie is not reflected in Cookies issued in Codeigniter4

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

CodeIgniter is a PHP full-stack web framework. In versions prior to 4.2.7 setting `$secure` or `$httponly` value to `true` in `Config\Cookie` is not reflected in `set_cookie()` or `Response::setCookie()`. As a result cookie values are erroneously exposed to scripts. It should be noted that this vulnerability does not affect session cookies. Users are advised to upgrade to v4.2.7 or later. Users unable to upgrade are advised to manually construct their cookies either by setting the options in code or by constructing Cookie objects. Examples of each workaround are available in the linked GHSA.

CVSS 2.6 · Faible · EPSS 1,1% · Correctif disponible

Publication
Mise à jour

Pile logicielle: php

Produits et versions concernés

  • codeigniter4

    Versions du logiciel
    • < 4.2.7: Concernée

    Aucun correctif publié

  • codeigniter4/framework Packagist

    Versions du logiciel
    • 4.0.0
    • 4.0.0-rc.4
    • v4.0.0-alpha.3
    • v4.0.0-alpha.4
    • v4.0.0-alpha.5
    • v4.0.0-beta.1
    • v4.0.0-beta.2
    • v4.0.0-beta.3
    • v4.0.0-beta.4
    • v4.0.0-rc.1
    • v4.0.0-rc.2
    • v4.0.0-rc.2.1
    • v4.0.0-rc.3
    • v4.0.1
    • v4.0.2
    • v4.0.3
    • v4.0.4
    • v4.0.5
    • v4.1.0
    • v4.1.1
    • v4.1.2
    • v4.1.3
    • v4.1.4
    • v4.1.5
    • v4.1.6
    • v4.1.7
    • v4.1.8
    • v4.1.9
    • v4.2.0
    • v4.2.1
    • v4.2.2
    • v4.2.3
    • v4.2.4
    • v4.2.5
    • v4.2.6
    Plages de versions concernées
    • ECOSYSTEM: < 4.2.7

    Mettez à jour vers 4.2.7

Sources originales

Vérifiez votre serveur →