CVE-2022-40617
CVE-2022-40617
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
strongSwan before 5.9.8 allows remote attackers to cause a denial of service in the revocation plugin by sending a crafted end-entity (and intermediate CA) certificate that contains a CRL/OCSP URL that points to a server (under the attacker's control) that doesn't properly respond but (for example) just does nothing after the initial TCP handshake, or sends an excessive amount of application data.
CVSS 7.5 · Élevée · EPSS 1,8% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
n/a
- Versions du logiciel
- n/a: Concernée
Aucun correctif publié
strongswan Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 5.9.8-1
Mettez à jour vers 5.9.8-1
strongswan Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 5.9.8-1
Mettez à jour vers 5.9.8-1
strongswan Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 5.9.8-1
Mettez à jour vers 5.9.8-1
strongswan Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 4.6.4-9
- 5.1.0-2
- 5.1.0-3
- 5.1.1-0ubuntu1
- 5.1.1-0ubuntu2
- 5.1.1-0ubuntu3
- 5.1.1-0ubuntu4
- 5.1.1-0ubuntu5
- 5.1.1-0ubuntu7
- 5.1.1-0ubuntu14
- 5.1.1-0ubuntu17
- 5.1.2~dr3+git20130120-0ubuntu2
- 5.1.2~dr3+git20130120-0ubuntu3
- 5.1.2~rc1-0ubuntu3
- 5.1.2~rc1-0ubuntu4
- 5.1.2~rc2-0ubuntu2
- 5.1.2-0ubuntu1
- 5.1.2-0ubuntu2
- 5.1.2-0ubuntu2.2
- 5.1.2-0ubuntu2.3
- 5.1.2-0ubuntu2.4
- 5.1.2-0ubuntu2.5
- 5.1.2-0ubuntu2.6
- 5.1.2-0ubuntu2.7
- 5.1.2-0ubuntu2.8
- 5.1.2-0ubuntu2.10
- 5.1.2-0ubuntu2.11
- 5.1.2-0ubuntu2.11+esm1
- 5.1.2-0ubuntu2.11+esm2
- Plages de versions concernées
- ECOSYSTEM: < 5.1.2-0ubuntu2.11+esm3
Mettez à jour vers 5.1.2-0ubuntu2.11+esm3
strongswan Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 5.1.2-0ubuntu6
- 5.1.2-0ubuntu7
- 5.1.2-0ubuntu8
- 5.3.5-1ubuntu1
- 5.3.5-1ubuntu2
- 5.3.5-1ubuntu3
- 5.3.5-1ubuntu3.1
- 5.3.5-1ubuntu3.2
- 5.3.5-1ubuntu3.3
- 5.3.5-1ubuntu3.4
- 5.3.5-1ubuntu3.5
- 5.3.5-1ubuntu3.7
- 5.3.5-1ubuntu3.8
- 5.3.5-1ubuntu3.8+esm1
- 5.3.5-1ubuntu3.8+esm2
- Plages de versions concernées
- ECOSYSTEM: < 5.3.5-1ubuntu3.8+esm3
Mettez à jour vers 5.3.5-1ubuntu3.8+esm3
strongswan Ubuntu:Pro:FIPS-updates:16.04:LTS
- Versions du logiciel
- 5.3.5-1ubuntu3.fips.3.4.1
- 5.3.5-1ubuntu3.fips.3.4.2
- 5.3.5-1ubuntu3.fips.3.8.1
- 5.3.5-1ubuntu3.fips.3.8.2
- 5.3.5-1ubuntu3.fips.3.8.3
- Plages de versions concernées
- ECOSYSTEM: < 5.3.5-1ubuntu3.fips.3.8.6
Mettez à jour vers 5.3.5-1ubuntu3.fips.3.8.6
strongswan Ubuntu:Pro:FIPS:16.04:LTS
- Versions du logiciel
- 5.3.5-1ubuntu3.fips.3.1
- 5.3.5-1ubuntu3.fips.3.2
- 5.3.5-1ubuntu3.fips.3.3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
strongswan Ubuntu:18.04:LTS
- Versions du logiciel
- 5.5.1-4ubuntu2
- 5.5.1-4ubuntu3
- 5.6.1-2ubuntu1
- 5.6.1-2ubuntu2
- 5.6.1-2ubuntu3
- 5.6.1-2ubuntu4
- 5.6.2-1ubuntu2
- 5.6.2-1ubuntu2.2
- 5.6.2-1ubuntu2.3
- 5.6.2-1ubuntu2.4
- 5.6.2-1ubuntu2.5
- 5.6.2-1ubuntu2.6
- 5.6.2-1ubuntu2.7
- 5.6.2-1ubuntu2.8
- Plages de versions concernées
- ECOSYSTEM: < 5.6.2-1ubuntu2.9
Mettez à jour vers 5.6.2-1ubuntu2.9
strongswan Ubuntu:Pro:FIPS-updates:18.04:LTS
- Versions du logiciel
- 5.6.2-1ubuntu2.fips.2.5.1
- 5.6.2-1ubuntu2.fips.2.7.1
- 5.6.2-1ubuntu2.fips.2.7.2
- 5.6.2-1ubuntu2.fips.2.8.1
- Plages de versions concernées
- ECOSYSTEM: < 5.6.2-1ubuntu2.fips.2.9
Mettez à jour vers 5.6.2-1ubuntu2.fips.2.9
strongswan Ubuntu:Pro:FIPS:18.04:LTS
- Versions du logiciel
- 5.6.2-1ubuntu2.fips.2.4.2
- 5.6.2-1ubuntu2.fips.2.5.1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
strongswan Ubuntu:20.04:LTS
- Versions du logiciel
- 5.7.2-1ubuntu3
- 5.8.1-1ubuntu1
- 5.8.2-1ubuntu1
- 5.8.2-1ubuntu2
- 5.8.2-1ubuntu3
- 5.8.2-1ubuntu3.1
- 5.8.2-1ubuntu3.2
- 5.8.2-1ubuntu3.3
- 5.8.2-1ubuntu3.4
- Plages de versions concernées
- ECOSYSTEM: < 5.8.2-1ubuntu3.5
Mettez à jour vers 5.8.2-1ubuntu3.5
strongswan Ubuntu:Pro:FIPS-updates:20.04:LTS
- Versions du logiciel
- 5.8.2-1ubuntu3.fips.3.1.2
- 5.8.2-1ubuntu3.fips.3.3.1
- 5.8.2-1ubuntu3.fips.3.4.1
- Plages de versions concernées
- ECOSYSTEM: < 5.8.2-1ubuntu3.fips.3.5
Mettez à jour vers 5.8.2-1ubuntu3.fips.3.5
strongswan Ubuntu:Pro:FIPS:20.04:LTS
- Versions du logiciel
- 5.8.2-1ubuntu3.fips.3.1.2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
strongswan Ubuntu:22.04:LTS
- Versions du logiciel
- 5.9.1-1ubuntu3
- 5.9.1-1ubuntu3.1
- 5.9.4-1ubuntu1
- 5.9.4-1ubuntu2
- 5.9.4-1ubuntu3
- 5.9.4-1ubuntu4
- 5.9.5-2ubuntu1
- 5.9.5-2ubuntu2
- Plages de versions concernées
- ECOSYSTEM: < 5.9.5-2ubuntu2.1
Mettez à jour vers 5.9.5-2ubuntu2.1