CVE-2022-41915
CVE-2022-41915
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Netty project is an event-driven asynchronous network application framework. Starting in version 4.1.83.Final and prior to 4.1.86.Final, when calling `DefaultHttpHeadesr.set` with an _iterator_ of values, header value validation was not performed, allowing malicious header values in the iterator to perform HTTP Response Splitting. This issue has been patched in version 4.1.86.Final. Integrators can work around the issue by changing the `DefaultHttpHeaders.set(CharSequence, Iterator<?>)` call, into a `remove()` call, and call `add()` in a loop over the iterator of values.
CVSS 6.5 · Moyenne · EPSS 1,0% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
netty
- Versions du logiciel
- ≥ 4.1.86.Final, < 4.1.86.Final: Concernée (custom)
- ≥ 4.1.83.Final, < 4.1.83.Final*: Concernée (custom)
Aucun correctif publié
netty Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 1:4.1.48-6
Mettez à jour vers 1:4.1.48-6
netty Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 1:4.1.48-6
Mettez à jour vers 1:4.1.48-6
netty Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 1:4.1.48-6
Mettez à jour vers 1:4.1.48-6
netty Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 1:3.2.6.Final-2
- 1:4.0.32-1
- 1:4.0.33-1
- 1:4.0.34-1
- Plages de versions concernées
- ECOSYSTEM: < 1:4.0.34-1ubuntu0.1~esm1
Mettez à jour vers 1:4.0.34-1ubuntu0.1~esm1
netty-3.9 Ubuntu:16.04:LTS
- Versions du logiciel
- 3.9.0.Final-1
- 3.9.0.Final-1ubuntu0.1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
netty Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 1:4.1.7-4
- 1:4.1.7-4ubuntu0.1~esm1
- 1:4.1.7-4ubuntu0.1
- 1:4.1.7-4ubuntu0.1+esm1
- Plages de versions concernées
- ECOSYSTEM: < 1:4.1.7-4ubuntu0.1+esm2
Mettez à jour vers 1:4.1.7-4ubuntu0.1+esm2
netty-3.9 Ubuntu:18.04:LTS
- Versions du logiciel
- 3.9.9.Final-1
- 3.9.9.Final-1+deb9u1build0.18.04.1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
netty Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 1:4.1.33-1
- 1:4.1.33-2
- 1:4.1.33-3
- 1:4.1.45-1
- Plages de versions concernées
- ECOSYSTEM: < 1:4.1.45-1ubuntu0.1~esm1
Mettez à jour vers 1:4.1.45-1ubuntu0.1~esm1
netty Ubuntu:22.04:LTS
- Versions du logiciel
- 1:4.1.48-4
- Plages de versions concernées
- ECOSYSTEM: < 1:4.1.48-4+deb11u1build0.22.04.1
Mettez à jour vers 1:4.1.48-4+deb11u1build0.22.04.1
Sources originales
- https://github.com/netty/netty/security/advisories/GHSA-hh82-3pmq-7frp
- https://github.com/netty/netty/issues/13084
- https://github.com/netty/netty/pull/12760
- https://github.com/netty/netty/commit/fe18adff1c2b333acb135ab779a3b9ba3295a1c4
- https://lists.debian.org/debian-lts-announce/2023/01/msg00008.html
- https://www.debian.org/security/2023/dsa-5316
- https://security.netapp.com/advisory/ntap-20230113-0004/
- https://nvd.nist.gov/vuln/detail/CVE-2022-41915